Posted on

Recent Updates to Store Locator Plus 4.6.4

Store Locator Plus version 4.6.4 fixed the zoom settings, the plug-in tabs “save changes” and the back-end UI.

The change in the back end user interface will not be noticeable to most users. The naming of sections and tabs and settings now will use programmatic slugs instead of the plain text names. This allows the settings translations in different languages to remain intact even if language files have not been updated. This means future updates to Store Locator Plus, Power, Experience, and Premier add-ons will no longer lose their settings tabs. Another behind the scenes development is populating the plug-in and add-ons with “smart options” settings. To learn more please watch the developer’s brief You Tube.

Change Log for Store Locator Plus

Posted on

SLP version 4.6.2 , Experience Add-on version 4.6.2 releases

 512px-model-view-controller_pattern-svg

Store Locator Plus 

You will notice a new look in your admin panel of Store Locator Plus in Version 4.6.2 .  Featuring  a new sidebar on the admin pages for the settings tabs and the locations tab.

Version 4.6.2 locations info sidebar added
Version 4.6.2 locations info sidebar added

Important fixes: SLP version 4.6.2  fixes the “white screen” error on sites running the older version of WordPress 4.4 and/or  Multi-site users running WordPress 4.6.

Enhancements:

  •  Show admin help settings in a new sidebar to make it easier to see what each setting does.
  •  Show location details preview in right sidebar on manage locations page.
  • Added links to direct documentation pages for various settings.
  •  Implement a new slp_get_text_string filter for add-ons to manage text strings.
  • Additional hard-coded gettext strings accessible to the text manager.
  •  Don’t load the SLP overhead on the WordPress admin heartbeat since SLP doesn’t  require  “heartbeat” processing. Wouldn’t it be nice if all plugins did that?

Fixes:

  • Multisite installs – upgrading SLP fixes “not an array” error that would cause white screen on upgrade      for sites using WP 4.6+
  •  Fix stripslashes_from_strings_only() undefined function for sites running old WordPress (you really should update to WordPress 4.4+ for security reasons if nothing else).
  •  Recalculate initial distance for all locations on global center map at change.

Changes

 Performance update: Drop adminUI create_InputElement() method.  (Note : This may break pre-4.2  Legacy Add Ons, you must  upgrade to the Legacy add-on  latest version release. 4.3 or higher or downgrade SLP to earlier version)

  •  Experience will need to be updated to 4.6.2 when updating SLP to 4.6.2

 

Experience Add-on 4.6.2

<h2>Change Log for SLP Experience Add-on</h2>

Posted on

SLP versions: Power add-on, Experience add-on version 4.6.1 updates to import functions

shem-001

Store Locator Plus 4.6.1 Highlights

• Allow add-ons to load JS on a per-admin-tab basis. Reduces browser overhead and memory footprint on admin pages.

• Simplify and improve the new option manager. More consistent option handling, more security option management, better performance.

•  Checkbox on/off validation for all add ons – fixes instant checkbox saving on admin panel for some add on options

• All language files are now pulled from the MySLP website.  • Missing translations? See MySLP and add your translation updates there.

Change Log for SLP Power Add-on

Posted on

SLP version 4.6, Experience add-on 4.6, Power Add-on 4.6 and Premier 4.6

The moment you all have been waiting  for is here. Updates to version 4.6  have been made to the core Store Locator Plus plug-in along with Power, Experience, and Premier.

Some of the new features and updates you will see in the core (base) plug in :

Enhancements

  • Manage Locations now has fast delete on single location delete icon.
  • Provides mechanism for add ons to serve per-admin-page specific JS.
  • If there is a newer version of an active SLP add on it will be shown on the WP plugins page.

Fixes

  •  Power Add On assignment of categories.
  •  Duplicates handling on location import.
  • Smart/fast option saving for add on packs including Power Add On import options.
  • Fix the  admin form drop down menus.
  • Eliminate the duplicate “are you sure you want to delete”  dialogue boxes on bulk actions.

Changes:

 

Power Add-on Users reported some glitches with version 4.5.12 imports. The duplicate handling updates has been fixed. Note: In order for the Duplicate Handling Update location to function, either the sl_id  or the Contacts field Identifier MUST be present and match what is stored in the location data field. To see the sl_id number you can hover over to the left of the location name under manage locations. Exporting the locations file to a csv file will also show the sl_id. This id is assigned automatically when a user adds a location in SLP for the first time and is not the one  you assign as an identifier with contact extender. The specific contact identifier field can be used instead of the sl_id and takes precedence.

Power 520x520

 

 

 

Posted on

Power add-on Release 4.5.10 fixes short code only_with_

Surprise!  He did it again…..our world traveler and developer supreme fixed a bug (..truth be told..he probably introduced the !oops! by muddling around with making a good thing great) that was discovered by one of our loyal customers who upgraded to the Power Add-on and shared it with us in the Store Locator Plus Support forum.

We also would like to thank the many new Power users and Premier Members who took advantage of  the latest sales campaign to  upgrade their Legacy add-ons.   Although our summer sales event is alas coming to a close,  you die hard Legacy add-on users can still request a coupon to upgrade to the new and improved Power add-on (with faster than ever importing functions, )  Experience Add-on group or our platinum Premier.  The coupon value will be determined as shown under the relevant  Product Descriptions.

Power Change Log

Posted on

Store Locator Plus 4.5.09, Premier 4.5.09 and Add-on updates

Store Locator Plus 4.5.09

SLP was updated to version 4.5.09 to allow for compatibility with those users who have a lower PHP of 5.5 or lower. WordPress recommends PHP 5.6 but we realize not everyone can get their host to upgrade. WP does provide verbiage (click on the link) to send to your provider host if you are interested in helping put the pressure on. When you upgraded the base plug-in to 4.5.09 and if you had a lower version of ProPack installed, you will see a notice that disabled 4.5 version of Pro Pack. You still have access to it and can upload the latest version (4.5.07). All you need to do is log into your account and download the latest version from there as noted in an earlier blog.

Pro Pack, Tagalong, Pages = Power

As many of you have noticed there have been changes that affect some of our most popular add-ons.  The latest updates to these add-ons were made for compatibility reasons as Store Locator Plus continues to evolve on its way to become lighter, more efficient and will use less of your overhead.  Pro Pack and Tagalong have joined the ranks of LEGACY add-ons and will not be updated further since the functionality and features have been moved or added to the newer Power add-on. Legacy add-ons will continue to work with the SLP version in use at the time the add-on was purchased
Continue reading Store Locator Plus 4.5.09, Premier 4.5.09 and Add-on updates

Posted on

Getting Started With Store Locator Plus

In June 2016 Google decided to extend their reach into tracking everything-and-anything online by requiring ALL Google Maps products and services to start registering their websites with Google.   We’ve updated our Getting Started With Store Locator Plus documentation and videos to include the Google Maps API registration process.   If you have any questions please contact us via the forums or by email.

You can get detailed instructions via the Getting Started article on our docs site.

The steps:

  1. Install the Store Locator Plus plugin.
  2. Get your Google API Key.
  3. Save it via the Store Locator Plus General /Server tab.
  4. Add a location.
  5. Add a WordPress page with the [slplus] shortcode on it.

 

Posted on

Store Locator Plus 4.5.08 And Related Changes

Store Locator Plus 4.5.08 was released today with several notable updates.

Disabled Add Ons

One of the most prominent “features” users are noticing is that their older add ons are being automatically disabled if they are not compatible with the latest Store Locator Plus release.   Having your add on disabled is preferable, at least for most site admins, than crashing your WordPress site.    So far in ALL cases the disabled add on has a NEWER VERSION available.  Login to your account at StoreLocatorPlus.com to download the latest version of your add on.

You can find the list of versions on the StoreLocatorPlus.com website.

Data I/O Performance

Changes in the extended data manager reduces the data I/O requests through WordPress by at least one, if not a few, data reads for every page load.   For sites with heavy traffic this can be a notable performance improvement on page load times.

Complex Data Query Support

Version 4.5.08 of the location query engine has been updated to allow “stacked” queries.  Stacked queries make it possible to perform complex location inquiries that were not possible with a single data request.  For example “show all locations with no territory assigned that are within X miles of a user  PLUS all locations with a territory that covers the user’s location”.    This change will allow future Store Locator Plus releases and the forthcoming My Store Locator Plus service to perform very creative location searches in real time.

Posted on

Google Maps Now Requires API Registration

There are some new Google changes that we anticipated nearly a year ago and is not specific to Store Locator Plus.

API Key

Effectively Immediately, all new websites that come online as of June 22, 2016 will require a Google Map API key.   This is no longer optional.  Store Locator Plus has had the ability to set a Google API key since version 4.  Go to the General / Server tab and enter your Google API Server Key.

SLP 4.5 General Server Settings
SLP 4.5 General Server Settings

You can learn more and sign up for a key from the Google Maps documentation site.

Google Maps API Limits
Google Maps API Limits

Location Sensor

Any users running Chrome including those using Android based web browsers will no longer be able to auto-detect their location using the location sensor unless the source site is running https.  That means that your website must have a valid SSL certificate.  If your site URL does not load when you use https:// as the starting part of your web address the location sensor provided by the Power Add On will not work.

Posted on

SLP version updates 4.5, Add-0n version updates and Premier subscription updates

The Store Locator Plus developer and team have been busy in the past months updating the base plugin and add-ons  to version 4.5 or higher. These include updates to add-on packs, Experience, ProPack, Premier, Power (in pre-release), and some of the more popular  third party add-ons  (User Managed Locations, Extended Data Manager, Event Location Manager, Social Media Extender, Gravity Forms Locations and Integration) to work with SLP 4.5 and WordPress v 4.5 or  higher.  If an add-on has not been updated to 4.5, that indicates it is either considered a legacy pack and/or included in a new Add-on.

As mentioned in the developers previous blog, WP 4.5  updated jquery which revealed many errors with themes and plugins that were not using latest versions or blocked/forced  jquery versions.   SLP uses the recommended jquery version 1.12 or higher.

User Managed Locations  4.5.03 by DeBaat

New feature: an Edit icon will appear in the [[slp]] results list on the front-end for only those locations the logged on user has access to. Clicking the Edit icon will lead to the manage page on the admin section so you would only need to allow the user access to that page.  By adding the text “[slp_location uml_buttons]” to the results layout, (changes to layout is available as part of the Experience add-on)  you can control the location where the Edit icon appears.

On a separate note, when Store Locator Plus released v 4.5.01 , a new set of issues were introduced  on the sites using the  Network Active Multisite  for WP.    Store Locator Plus version 4.5.05 fixed those issues as  noted in the release notes and the video.  This revealed  how many sites were using the SLP add-ons  but not purchasing for each site they were running for their customers.  This was contrary to the rules of business licensing that had been requested from the start.  Therefore, an active Premier Subscription is requested for any sites running network-activated Store Locator Plus with paid add ons.  For further information see the below videos.

VERSIONS AND RELEASE NOTES

SLP 4.5.03 combined with updates to Pro Pack, Power , and Experience add – ons resolve some issues with incomplete translation files (.po and .mo) files causing settings to not be found.

Posted on

WordPress 4.5 Breaking JavaScript (aka Where Is My Map?)

Ever since WordPress 4.5 rolled off the press there have been numerous complaints about websites breaking.   Numerous reports are coming into our Store Locator Plus forums and support email telling us “our map broke when they updated our website”.  The problem?  jQuery. To be more specific the problem is not jQuery but  how some plugins and themes implement jQuery in WordPress.

WordPress 4.5 started shipping jQuery version 1.12.3 as the “official” version of jQuery being used  with WordPress core. jQuery 1.12 has more stringent controls than previous versions.   The most obvious, jQuery 1.12 no longer “hides” some of the syntax errors that lay dormant in plugin code.   If there is malformed  or incorrect syntax, jQuery 1.12 will complain.  Your browser will most likely stop executing ALL scripts from that point forward.  As you can imagine, this causes things, like themes and plugins  to break.
Continue reading WordPress 4.5 Breaking JavaScript (aka Where Is My Map?)

Posted on

Store Locator Plus Version 4.4.36 released along with Experience Add-on 4.4.10

Folly-governeth-the-world-alfred-crowquill-1860
Store Locator Plus base plug-in was updated and published April 1, 2016.

The main change is within the zoom level adjustment for the map as noted in the developers blog this past week.

This update also added  a new Documentation button , displayed as a globe in the top right hand  corner of the pages in the  Admin panel  to link to the new Documentation site, and fixed some broken links under the help text.  The help ? question mark is transparent until you hover over it to the side  of the setting you are reviewing.   The New Documentation site is being populated with posts instead of pages, which should make it easier to search by tags, keywords or categories,  without getting  general blog posts and various other pages /posts in results.

If you have suggestions or need additional information  on where to find  something , such as “how to” settings,  please post in the forums.  Forums are free support and is the best place to start.  We ask that you provide your Plugin Environment and (just as important) if the question is  specific  to your site,  the direct url  that links to  your SLP or locator page.  This saves us both time and allows the support team to quickly find your page and respond in kind.

Experience Add-On

Experience 520x520

The latest release v. 4.4.10 adds a function that was requested by one of our long standing  Premier  Members.  The added  feature  allows an administrator to  add the short code [[slplus disable_initial_directory=”1″]] on a separate page.   Utilization of this shortcode provides the  ability to “Disable Initial Directory” on a single page via the shortcode and still have the ability to “Show Locations At Startup”.

VERSIONS AND RELEASE NOTES

 

Posted on

SLP Zoom Controls

Store Locator Plus 4.4.36 has an adjustment for zoom controls that addresses a change in the Google Maps API.

In older releases of the Google Maps JavaScript API the rendering engine would often render the map with one-or-more pins on the edge of the map. These pins would often be inaccessible as they fell under the Google map controls. Sometimes the info bubble would be cut off. The Store Locator Plus JavaScript interface would adjust for this by pulling the zoom level back one level on anything other than the 3 widest views (global zoom levels) which were not affected by the edge-of-map anomaly.

SLP Google Pins Cut Off (older Google API)
SLP Google Pins Cut Off (older Google API)

In the continued Google Maps JavaScript API improvements the edge-of-map pins stopped happening. It wasn’t until recent customer feedback that we realized this had changed. In Store Locator Plus 4.4.36 the zoom tweak is no longer auto-adjusted for non-global views of the map. Store Locator Plus will now use the Google default bounding boxes which keeps all pins within the map bounds. The info bubbles also auto-adjust to bring the entire bubble into focus on the map to prevent text from being cut-off.

SLP Google Normal Pins
SLP Google Normal Pins
Posted on

Release Updates: Store Locator Plus 4.4.34, Pages 4.4.07, and Extended Data Manager 4.4.02

Sculpting_La_Silla’s_Skies

Store Locator Plus 4.4.34

Highlights:

  • Added: a new feature to Reset (not to be confused with REST) your locations display under the General Admin tab without having to load Janitor to fix the _option_nojs admin locations per page.
  • Fixed: the “SLP did not send back a valid JSONP response” error message. This bug was discovered when a Premier customer had a combination of settings in the radii options under the experience/ search along with some other check boxes.
  • Updated: to accomodate REST API v2

Continue reading Release Updates: Store Locator Plus 4.4.34, Pages 4.4.07, and Extended Data Manager 4.4.02

Posted on

Release Updates: SLP 4.4.30, Pages 4.4.06, and Pro Pack 4.4.04

Store Locator Plus

Store Locator Plus developers have been busy with a lot of coding to prepare for the transition to a better and, hopefully, smoother internationalization and language translation process with add-ons and/or updates to the base plug-in. Translation files will no longer need to be 100% updated and accurate to prevent the settings strings from “dropping off”. This is the first iteration of several that will slowly convert all admin settings to be language “neutral”. The release also includes some minor performance improvements and an update to the German language file thanks to one of our Store Locator Plus customers. Tutorial and informational videos (on this release as well as “How to” instructional videos) can be viewed on the Store Locator Plus YouTube channel.

Pro Pack v 4.4.04

Pro Pack has also been updated to address two known issues. The first issue that may not be apparent to many users was found in the Pro Pack Reports. Pro Pack Reports were creating duplicate indexes.That has been patched. The second issue that was reported was with remote import functions set for a chronological upload. The schedule import time has to be set to seconds not the top of the hour, (NOT a time like 14:00 as noted in the help text). The help text in Pro Pack has been fixed to clarify.

Import CRON
Import CRON

Pages v 4.4.06

A bug was found in a past Pages release causing Pages to reset the custom Page templates and also resetting them back to draft whenever locations or other info in your location database was changed. That has been patched in 4.4.06

As a side note, if you missed the 2016 Future Forward announcement, both Pages and Pro Pack will be included in the new Power add-on, estimated to be ready for production in April 2016.

The technical background for Pro Pack release notes, Pages release notes and Store Locator Plus 4.4.30 are explained in the below videos