Can't Delete Locations — Reappearing in Database After Deletion

Home Forums Store Locator Plus Can't Delete Locations — Reappearing in Database After Deletion

This topic contains 5 replies, has 4 voices, and was last updated by  Claus 1 year, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #22394

    joshgilmore1
    Participant

    When I try to delete locations manually (not using Janitor), they reappear gradually. Even viewing or editing in PHPMyAdmin, the same effect/error is occurring. I’ve tried deactivating plugins and typical fixes, but nothing seems to work. Does anyone know what might be causing this? Will Janitor resolve the issue? Thanks in advance.

    #22398

    joshgilmore1
    Participant

    Once all the locations reappeared, I used Janitor to remove the locations, which seemed to clear them permanently. It still seems strange that I wasn’t able to delete any of the locations manually.

    #23103

    Lance Cleveland
    Keymaster

    I’ve not seen that before.    No error messages in log files?
    If it happens again turn on WordPress debugging and see if any error messages are logged:

    /documentation/store-locator-plus/troubleshooting/#debugging

    #23571

    Liz
    Participant

    I seem to be having a similar problem and would like to ensure my locations are deleted properly. I’m confused by the description of what Janitor does – it states it will not delete the location data? Also, I do not wish to reset all my settings. Could you clarify please.

     

    Thanks. Steve

    #23794

    Lance Cleveland
    Keymaster

    The Janitor now has the ability to reset settings, delete locations, and modify related add-on pack data.   They are all separate maintenance tools within the Janitor add-on pack.

    The locations should NOT require the Janitor to delete them.   Deleting locations from the location manager should delete the locations and all related data.

    #29990

    Claus
    Participant

    Did you get this solved. I have the same problem. Deleting all via janitor and then they reapear!

    Have made a shot screenrecording:

    https://www.dropbox.com/s/r3hkhl1kzhlzbzb/StoreLocatorPlus.mov?dl=0

    • This reply was modified 1 year, 6 months ago by  Claus. Reason: Added link to screenreording
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.