Country selector is not working

Home Forums Store Locator Plus Country selector is not working

This topic contains 4 replies, has 3 voices, and was last updated by  Lance Cleveland 1 year, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #30628



    I recently bought the “enhanced search” add-on . And one of the function I’m looking for is country selector. It’s somehow not working. When I select United States, it displays “NO RESULTS FOUND.” instead of the list of retailers.

    If there any settings I might miss? or could you take a look?



    • This topic was modified 1 year, 5 months ago by  TaiChing.



    Please check all of your settings under the tabs, Map and User Experience is where you will find the settings for Search and Results, they go hand in hand:
    Do you have immediately show locations “ON” or off?






    Hi Cici,

    I have “Immediately Show Locations” checked. And I’ve read through all of the links you provided before I sent out the question…

    But the country selector is still not working as expected:
    1. Is there a way we can show the error message when user selects “Australia” but types in US zipcode? Currently it’s still displaying search result based on the zipcode.
    2. Is there a way users can search based on ONLY the country they selected? No need to input Zipcode and city? currently this doesn’t work.




    Everything is working on my test site and I have multiple countries in my test set. I can even type in China in the zipcode box and the map reflects the location I have in China.

    Under Selector Behavior there is a Disable option, click on the question mark to see what this function does.

    You also have the option to Customize the search , in the Search Layout box you can add or delete using Enhanced Search Shortcodes.

    I do not know of a way to tell people they typed in a zipcode for the US that is actually for Australia, There has to be a logical method to render the map and best guess based on the information the user enters.. You can add any text you would like in the Search Placeholder ti.e. “ry again or enter correct conuntry”

    If you want additional functionality, as to the results that are shown and what verbiage appears on the map page once the search is rendered …you would need the Enhanced Results Add-on.

    As mentioned I would fool around with your dropdown features. And add the text in search Placeholders that if they do not enter anything that you have for locations it will just say “enter country, or enter Zip code or whatever and try again”

    Other than that, I cannot quite figure out what you mean by “the country selector doesn’t work as expected.”

    BTW: I do not know what you have installed , which versions etc. If you read under “read this About forums” it tells you the information needed.


    Lance Cleveland

    Change Radius Behavior (User Experience / Search Form / Search Features section) to “Use only when address entered”.

    Change Country Selector to Dropdown / Discrete Filter.

    Change Selector Behavior to Disable Address When Using Selector.


    What This Does

    Radius Behavior = only when address entered = set an “infinite radius” from the center of your country UNLESS someone types an address in the address box.    So if a user leaves the address blank it will show ALL locations (up the the maximum results you set).

    Country Selector = discrete = do a match of all locations within the database that have the country set to the exact entry shown on the drop down.  Combined with Radius Behavior this will show all locations anywhere in the world that are in this country (up to the maximum results).

    Selector Behavior = Disable Address When Using Selector = do NOT allow someone to use both the country drop down AND type in an address (this can create some odd results in most cases).   Since radius is set to “ignore if no address entered” this will ensure that if someone selects a country from the dropdown the address field is blanked out and thus return all locations in the selected country.

    To change the maximum results returned go under User Experience / Results and change the “Max Search Results” entry.  It defaults to 25.  Remember some browsers are slow and showing 2,000 locations may cause problems for your users.  Leave it at a smaller number such as 25.




Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.