Directory & Tagalong Short code works in 1 instance, but not another?

Home Forums Store Locator Plus Directory & Tagalong Short code works in 1 instance, but not another?

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 1 year, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #34301

    Tisha
    Participant

    I am using both tagalong and directory on this site.

    I am using this shortcode on one page in my site and it works perfectly. (http://mycirclek.com/car-washes/)

    [slp_directory  by=”city” style=”list_with_count” landing_page=”/locations/” filter_by=”sl_tags=’Car Wash'”]

    On another page (http://mycirclek.com/kickbackforschools/), I am trying to use this code:

    [slp_directory  by=”city” style=”list_with_count” landing_page=”/locations/” filter_by=”sl_tags=’Kickback'”]  (note the only difference is the tag name)

    And it will not work. There are locations with this tag, I’ve checked the name as an exact match to the category that exists.

    I’ve checked the html code, there aren’t any errant characters in the shortcode.

    If I change it back to ‘Car Wash’ this code works perfectly also on this page.

    Why can’t I filter on different pages in different shortcode? What am I missing?

    #34356

    Cici
    Keymaster

    In order to better assist you we need the information outlined in Posting Guidelines

    Also refer to the documentation about Shortcodes, and the WP dictonomy   (Blog about how WP works with Tagalong) . Also search teh forums for other explanations.

    Cant be more specific without your Plugin environment info

    #34361

    Tisha
    Participant

    As requested – please see the screenshot of the plugin environment. All plugins are running the latest versions. The theme is a modified Genesis Studiopress theme.

    I am using both tagalong and directory addons on this site.

    I am using this shortcode on one page in my site and it works perfectly. (http://mycirclek.com/car-washes/)

    ‘[[slp_directory  by=”city” style=”list_with_count” landing_page=”/locations/” filter_by=”sl_tags=’Car Wash’”]]’ (See text screenshot)

    On another page (http://mycirclek.com/kickbackforschools/), I am trying to use this code:

    ‘[[slp_directory  by=”city” style=”list_with_count” landing_page=”/locations/” filter_by=”sl_tags=’Kickback’”]]’  (note the only difference is the tag name)

    And it will not work. There are locations with this tag, I’ve checked the name as an exact match to the category that exists. (See Screenshot)

    I’ve checked the html code, there aren’t any errant characters in the shortcode. (see screenshots)

    If I change it back to ‘Car Wash’ this code works perfectly also on the kickback page.

    Why can’t I filter on different pages in different shortcode? What am I missing?

    Attachments:
    You must be logged in to view attached files.
    #34530

    Cici
    Keymaster

    Hmmm, that is a puzzler…something doesn’t like that slug for some reason I couldn’t see anything blatantly obvious.

    So if the only thing that is different is the tag name , have you tried doing anything like renaming the slug?  The WP taxonomy may be in play here since the Tagalong interacts  and is dependent on the WP rules and codex.

    Have you tried debugging with Firebug to see if there is something squirrelly going on behind the scenes?

     

    #34656

    Tisha
    Participant

    Hi,

    I tried changing the category slug and it did not resolve the issue. Any other suggestions?

    #34747

    Cici
    Keymaster

    Did you read the Documentation to ensure you have it set-up correctly? Do you have Enhanced Map? Are you trying to have it redirect to a map on a separate page?

    Did you check the Troubleshooting documentation? Have you tried debugging using Firefox? There is a tutorial video on debugging

    #34753

    Tisha
    Participant

    I have this function working for all but one category. I don’t think there is an answer for this in your documentation I am pretty sure that it is set up correctly because it is working in all instances but one…

    I can not see the issue in firefox debugger…do you?

    What is the process for the 30-day money back guarantee, for both of the plugins that I purchased. I will just have to find another alternative…

    #34807

    Cici
    Keymaster
    #34808

    Cici
    Keymaster

    Also, There is a Pre release 4.3.01 download available to update to a newer version of  Tagalong.   You can try the Pre-release on your dev site to see if that fixes your issue.

     

    #34879

    Cici
    Keymaster

    Tisha,

    I spoke to the developer, I wasn’t sure if how you were trying to use Directory Builder with tagalong worked, Since I had never seen it used that way before.

    Short answer it doesn’t.

    Directory Builder is built to create directories filtered by places (Cities) and locations, not by Tags or store categories. That functionality  has not been developed.. If that is a feature you absolutely want to have, you can speak to the Developer about a customized solution and pricing, under Paid Customization

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.