Errors and downgrading help.

Home Forums Store Locator Plus Errors and downgrading help.

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #42824

    Andrew
    Participant

    Good day,

    I’m coming into this situation at the tail end so please pardon my lack of info.

    This morning a site I was asked to fix had SLP 4.6 Updated pro pack and enhanced map.

    There was a visual error pointing to functions.php, I thought it would be best downgrade to make all add ons and extensions have similar versions (4.3X).

    At the moment we have SLP 4.3.24 most of the add ons are 4.2 and 4.3.

    now there is no visual error but there is also no map, and when i go to search it directs me to the home page.

    Can anyone assist?

     

    #42845

    Cici
    Keymaster

    What version WordPress do you have? Check WP version update , post about how old jquery versions effects SLP and generating of maps. (Are all your themes and other plugins updated and using jquery 1.12 or higher?)

    WP 4.6 and SLP 4.6 was tested with ProPack 4.5.07 without issues. It would be better for your customer to update to the newer replacement add-ons (see FAQ) instead of downgrading everything else. I would suggest you make sure it is an actual issue with SLP before downgrading.  Those older versions are no longer supported nor maintained.

    Using old WordPress versions and/or  plugins could leave you open   to security risks. WordPress and the SLP developer have  noted and written about WP hacks and security risks on a number of posts.

    If you need more advanced Web Development services and/or additional technical help with your overall WordPress site, or need design updates, or platform recommendations, I recommend Cyber Sprocket Labs @ Cybersprocket.com ,  our   Web Presence team of expert developers, software engineers and graphic designers.

     

     

    #42846

    Andrew
    Participant

    The issue is this… they have ALOT of add ons and i’m trying to minimize expenses on finding a solution we are using an updated version of WP. I have tried to use the upgraded version os SLP along w/ upgraded map and propack and still getting errors. If i had the user who purchased these plugins in the beginning i could login and get updated versions of all add ons. But the developer who was hired has now vanished and can’t be found.  so here we are….

    #42849

    Cici
    Keymaster

    Yipes. Can’t tell you how many times we have heard that story, or that a plug-in was abandoned and cant be updated (which is one of the reasons the cybersprocket was relaunched, these guys aren’t going to disappear).

    1) If you send an email to support we might be able to help you with the account access if we have enough information, such as  the name of the company but you do not need that info if you do upgrade buy purchasing the Power add-on.   2) Adding Power and or Experience eliminates multiple legacy add-ons, same reason you have cited,  and why the developer of SLP did that.  He was having to update and maintain over 20 separate plugins every time WP updated and they had a domino effect.    3) The new versions  are  faster with imports and uploads and are being maintained and updated.

    If you are using WP above 4.5…you will have little choice other than to update your theme or other plugins if there are conflicts with versions of jquery. Any plugins or themes need to be 1.12 or there will be conflict with other plugins and consequences, such as SLP maps not showing.

    You can minimize expenses and request  a discount  coupon for any of the featured add-ons by taking the hosting survery

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.