Extended Data Short Code Not Working

Home Forums Third Party Add-ons by Debaat Extended Data Short Code Not Working

This topic contains 5 replies, has 3 voices, and was last updated by  DeBAAT 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #43652

    Jackie
    Participant

    Greetings!

    I saw a topic with similar subject. However, whenever I use the proper shortcode [[slp_location data.slug_here]], the html only outputs the short code as if it’s not recognized: [[slp_location data.slug_here]].

    Are their any other plugins required to make this work properly? I the core slp and extended data.

    Thanks!

    Joe

    #43689

    Cici
    Keymaster

    When Posting  (see posting guidelines to obtain best results) ,please provide your plugin environment to include versions and if you can a screen shot of what you are trying to accomplish.

    Make sure you have the shortcode as html and could you show where you are placing this shortcode? It works best with the Experience Add-on if you are changing something in the results layout. you need an add-on to change the layouts.See the documentation 

    Extended Data is a third party Add-on  by DeBaat.  You have posted in the correct forum. I am assisting  for SLP by obtaining information so he can better assist you when he is back on line.

     

    #43730

    Jackie
    Participant

    The shortcode is being placed inside the style editor. Inside Experience-View

    • This reply was modified 1 month, 1 week ago by  Jackie.
    • This reply was modified 1 month, 1 week ago by  Jackie.
    • This reply was modified 1 month, 1 week ago by  Jackie.
    Attachments:
    You must be logged in to view attached files.
    #43764

    Jackie
    Participant

    Ok so check it before you wreck it. Lemme explain the entire scenario. We have the standard SLP core and SLP Pro (Legacy) We’re trying to add approximately 10-12 custom fields using extended data manager. (See screen shot)

    Whenever we add the short code, nothing happens at all. The shortcode comes out in the html as nothing – as if the shortcode isn’t recognized. I believe it’s structured properly: [[slp_location data.slug_here]]

    Is it possible the Pro Pack doesn’t entirely work with extended data manager? Do we have to use Experience or Power to get this to work right?

    • This reply was modified 1 month, 1 week ago by  Jackie.
    Attachments:
    You must be logged in to view attached files.
    #43780

    Cici
    Keymaster

    Jackie,

    So the screenshot of your plug-in environment is not accurate or current? I do not see ProPack with a version on that screen shot. Did you update to version 4.5.07?  Where are you putting the shortcode in the divvie, you sat style editor, do you mean CSS? That shortcode should be added within the Results Layout or whichever layout  you want it to appear in using the Experience add-on (unless you have another legacy product that is not appearing in your screenshot).  With Experience you can change any of the Locator Layouts: i.e. Search, Map or Results.

    I do not have any Enhanced Legacy add-ons installed but I can tell you with the ProPack Legacy and just Extended Data Manager there is no where to add what you are referring  to and have it work as far as I know.

    See under the product description: Extended data fields can be placed in search results, map info bubbles, and on Pages templates.

    Under EDM documentation

    so what you need is the Experience add-on if you intend to add the slug to appear within your results or in the map bubble etc. (More Info about the Experience Add-on is within documentation to assist you with the layouts and appearances and  options)

    #44078

    DeBAAT
    Moderator

    Hai Jackie,
    Can you provide a screenshot of the edit screen where you edit the shortcode?
    It may be the case that the double brackets “[[” are causing the issue.
    ‘normally’ the shortcode handling function of WordPress recognises the double brackets and interprets this as to show the shortcode as is instead of processing the shortcode.
    If you would like the shortcode to be processed and replaced by the value of the data element, you might want to enclose the shortcode in single brackets only “[“.
    Hope this helps.
    Best,
    Jan

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.