Import not working

Home Forums Store Locator Plus Import not working

Tagged: 

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 2 weeks, 1 day ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #43875

    Nikki
    Participant

    Currently running store locator 4.6.3 with pro pack 4.5.07 and have it scheduled to import daily. Up until recently the import has been functioning just fine but lately none of the new locations are being uploaded. The csv file is located on box.com and I have the direct link posted in the CSV file URL. I’ve also tried creating a new csv file with just the new locations and tried to import but it won’t work. Ive attached our file for reference. Please help.

    Attachments:
    You must be logged in to view attached files.
    #43886

    Cici
    Keymaster

    Hi Mikki

     

    You csv file looks fine. Could you provide more info?  Are you using the remote server upload?  Check to make sure the directory file path is still correct (i.e if http vs https)and permissions and security is not blocking it. Nine times out of ten that is the issue. Also what error logs are you seeing if any? Are you providing sufficient time to upload?  I notice you have the sl_id which indicates the locations are already in your location management and have been assigned a number by SLP.  Are you selecting the Duplicates handling that you want, i.e skip or add. etc.

    The documentation gives you more tool tips : See  handling the Duplicates and remote server imports and large import lists. 

     

     

    #43891

    Nikki
    Participant

    Hey Cici,

    I believe it is the remote server upload. I’ve tried copying the direct link again to make sure it was correct and still no luck. I’ve copied the link below and attached a screenshot of our settings. Security setting allow anyone with the link to download it. As for duplicates handling, I have it set to update. Let me know what other suggestions you might have.

    https://mypakage.box.com/shared/static/sr8edanoluefxvdvcgrqqtm4kzsgyaqp.csv

    Thanks,

    Attachments:
    You must be logged in to view attached files.
    #43895

    Cici
    Keymaster

    Hi Nikki,

    These are the steps I took to import your file.

    1) I downloaded and opened into my Google sheets

    2) I deleted the sl_id column since I did not have the same sl_id as you so it was not pertinent for my test

    3) I deleted hundreds of rows at the bottom so i wouldnt bog down my test site with locations I would then be deleting.

    4) I imported the csv file using the regular import manual (not remote server but off my own computer folder

    5) I skipped geocoding since you already have the lat/long and this will save bith time and not count against my google data query limit

    6) All of your sites imported in a nanao second.

    I have attached the screenshots.  Keep in mind that I have the Power add-on. If you do not have the latest versions your screen may not look the same.  My results show that either your sl_id is not matched correctly, or the file is taking a long time to load or you have exceeded your daily google query limit. But until you update your add-on I cannot be sure.

    I am using SLP 4.6.4 and Power 4.6.4 and I downloaded the csv file to be saved on my computer and then uploaded the csv file same way.

     

     

    Attachments:
    You must be logged in to view attached files.
    #43899

    Cici
    Keymaster

    Step 2, Now that I have imported 23 of your locations I now exported my locations with the sl_id.  I then made changes to two of your locations. I changed the names of the first two in my list. I changed 16 West to 16 North. I then left in the sl_id so that it would update any duplicates, I skipped geocoding again. I made no other changes to the list. Again it uploaded quickly and the changes were reflected in my locations panel.

    I changed 4 Starrs to 5 Starrs, I made no other changes. See attached screenshots.

    • This reply was modified 1 month ago by  Cici.
    Attachments:
    You must be logged in to view attached files.
    #43903

    Cici
    Keymaster

    The reason I did not upload using the remote server was because your list is too long for my test site. I can have the developer look at it when he has time, I do not know how soon that will be since he is currently tasked with helping a Premier customer with a migration through the customized paid support.

    If it is the remote server routine , can you download via a direct upload instead? If you are not getting any error messages perhaps it is just taking more time?   I do not recall what the remote back end looks like with the ProPack legacy so it is difficult for me to assess. The new system with Power is much better, would suggest you update to Power if you haven’t as yet, otherwise will have to wait in queue to see what may be happening, but as mentioned your proPack is very outdated and that needs to be rectified at the very least to 4.6.4 on ProPack. . I am not sure if the developer is going to be fixing any issues in Legacy add-ons unless they are security patches, but if he is fixing them, they are at the bottom of his to do list.

    #43930

    Nikki
    Participant

    Hey Cici,

    We’ve made sure that everything is up to date but none of my locations are importing or updating. Secondly, if I try to upload the file manually, it just brings me back to the store location query screen and does not attempt to upload anything. I have tried downloading all of my existing locations and saving it to a csv but the same thing happens when trying to upload manually. I have also tried checking the skip geocoding box with no luck. Please advise what I should try next.

    #43952

    Cici
    Keymaster

    I am at a loss as to how your site and/or WordPress is set up.For instance do you have “Force Load Javascript” checked off for some reason?

    It would really be helpful to see a screenshot of your Plugin environment, if we could see the php version and mysql etc.

    If you cannot even manually upload from a zip file on your local computer then it is not the remote file retrieval.

    Do you have full user permissions? Are you using Multi site?
    Please review the Troubleshooting guide.

    Something is broken on your site that I cannot replicate. Can you try debugging (how to is also nder the troubleshooting) and sending any errors to us at support?

    I have added this to his “please take a look list” but if you cannot wait and need immediate assistance he will need to schedule a time with you for IMMEDIATE one on one support requiring the developer to login to your site you would need to select the paid support login option. You will need to also make sure your site is backed up.

    #44035

    Nikki
    Participant

    Hey Cici,

    It looks like we did have Force Load Javascript checked, but I removed that and still the same issue. I’ve attached a screenshot of our plugin environment for your reference. As for debugging, I will work with our site administrator tomorrow and send any information possible. Would upgrading to the Power potentially solve this issue moving forward?

     

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #44057

    Cici
    Keymaster

    about ForceLoad, that function was added because of the way some themes are written so it was a work around. So that makes me wonder if it is something  in your  server configuration or theme, so even unchecking the box may not help. See the section in Troubleshooting about that function. It could be a combination of updates.

    The Power add-on is definitely quicker and more efficient and uses less overhead for imports so it might help but the Pro Pack has been tested with  version 4.6.4 of SLP and it hasnt stopped working as far as I know. No one has reported it not working and  I had no problem with your file but if there is an issue with the remote server uploads only with ProPack,  it  could take longer to track it down if you have some special configurations or javascript.

    If you do want to update to Power send an email to support and ask for a coupon towards it since you already have proPack.

    Since there is only one person doing the coding changes/ fixes, to achieve the efficiency he needed , the decision was made to not have  30 add-ons that would require updates and re work every time something in WP or the core plugin or Google API changed.  ( See his blog about the add-0ns in December 2015 and  March 2016)

    I wish I could help more, I am at a loss as to what could be happening.   Please keep me informed if you find something  in the meantime

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.