Input label text

Home Forums Store Locator Plus Input label text

This topic contains 13 replies, has 2 voices, and was last updated by  Cici 5 months, 4 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #41076

    Mark
    Participant

    Hi,

    I have a view questions concerning the experience add-on.

    In a previes version I chached the labels on the results like: Hours, Website, Routing etc (see attachment).

    But after the latest update, I can’t change dees labels.

    So what happend? How can I change them??

    Thanks for a quick replay.

    -Mark

    Attachments:
    You must be logged in to view attached files.
    #41100

    Cici
    Keymaster

    Hi Mark,

    Could you provide me with your Plugin Environment, versions add-ons etc? A screenshot is best, as well as your site url that has the locator page.

    (see Posting Guidelines for info we require to better assist you)

    Thanks

    #41111

    Mark
    Participant

    Hi Cici,

    See the attachments.

    Site URL: https://www.beveltools.com/find-a-store-near-you/

     

    Attachments:
    You must be logged in to view attached files.
    #41120

    Cici
    Keymaster

    Hi Mark,

    I do not see the Experience add-on as part of your Plugin Suite, I see ProPack and Tagalong.  Did you mean under the Experience tab (I know it is confusing) .  Are you using WP 4.5.2? If you roll back to SLP 4.4.37 do your labels save?

    Note:  I do not know if this has anything to do with it, I hope not but when I did a quick inspection of your site, it did show some failures, you might want to debug , if you need tutorial on that, see Troubleshooting:  These are the errors I saw on your site when I used tools/console.  Has your theme been updated to use current Jquery versions?

    jquery.js:2 Uncaught TypeError: Cannot read property ‘replace’ of undefined

    https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C300italic%2Cregul…0%2C700italic%2C800%2C800italic%7CLato%3Aregular&subset=OpenSans&ver=4.4.2 Failed to load resource: the server responded with a status of 400 ()

    #41128

    Mark
    Participant

    Hi Cici,

    I don’t have the experience add-on, I have the tagalong and the Propack. Yes I meen under the experience tab.

    I have not updated my theme because the update is horrible, it messes up woocommerce and lots of other stuff. So it might not been using the most current Jquery version.

    How do I roll back to 4.4.37?

    Is Janitor add-on free?

    Have you got an idea on what that error might be? It might be a CSS thing, it should call the “Open Sans” Google font but it won’t.

     

     

    #41130

    Cici
    Keymaster

    Janitor is free yes…You have a back up of your site right?

    You can go to WP directory and load any version of SLP from there.    I am not sure if that will fix your particular issue.

    WP has issued some warnings of late about security.   All plugin and your theme authors should be fixing and updating to keep current with WP best practices, yes when they change things it causes a ripple effect, but it goes with the territory of developing plugins and themes. The author  always suggest people have back up of their WP sites for that reason there are some inexpensive  plans out there, but that is a different subject

    #41131

    Cici
    Keymaster

    Janitor is free yes…You have a back up of your site right?

    You can go to WP directory and load any version of SLP from there.    I am not sure if that will fix your particular issue.

    WP has issued some warnings of late about security.   All plugin and your theme authors should be fixing and updating to keep current with WP best practices, yes when they change things it causes a ripple effect, but it goes with the territory of developing plugins and themes. The author  always suggest people have back up of their WP sites for that reason there are some inexpensive  plans out there, but that is a different subject

    #41448

    Mark
    Participant

    Hi,

    It should not matter if my theme is up to date or not. What if theme development stops because the author quits his business…? So I don’t think that’s the issue. I think it’s strange that I could change the labels and after updating SLP I can’t change them anymore, and now I am stuck because my client doesn’t want that labeltext (plus: the site WPML now, and I can’t find the labelinput texts anywhere in string translation, but that’s another issue).

    So I think you should have a solution to this problem. I think your product has an actual error, since I could make changes after buying it, and now, after updating, I can’t.

     

    #41457

    Cici
    Keymaster

    Changing the labels in that is part of the base plugin, do you mean what appears on the back end or the front end?  I am not sure where your issue is coming from.  I just deactivated all my add-ons (except propack and tagalong like you have), I went in and changed theExperience/Results/  label for phone to MYPHONE. saved changes, went to front end, voila it is MY PHONE in results.  So I am not sure what is causing you to have problems on your site I am afraid.

     

    Concerning the Themes, keeping up with  developmen etc. , that is totally a WP issue. It is coming from WP . Wp updates quite often and has had some major updates. We have no control over that and we cannot make SLp to work with every old version of various plugins and themes, so the developer does the right thing and updates to make it work with the current version of WordPress.   WP updated to 4.5 and are using the newer version of jquery, they have advised everyone to update and have noted that some themes that were poorly constructed or perhaps didn’t use best Practices were forcing javascript versions or Blocking jquery.   They have a list of the bad boys themes and have advised users , if ther theme author that is from a commercial side wont update, perhaps change your them to a WordPress theme (their words) they also have no control of the free market commercial themes.

    The developer of Store Locator Plus understands all too well about abandoned WP lpugins and that is how he got into the WordPress world to begin with. (about his background) . That is why he and many others have offered Paid Add-ons that need to be purchased.   Otherwise it is just a hobby and people tire of hobbies. The intent is to be able to continue providing updates and maintenance and support, to attend WordCamp conferences and keep up to date on WordPress changes and new developments.

    Store Locator Plus is JavaScript intensive. The author wrote a blog about it here.  and wrote about Themes and their function or non function a few more times , all the way back in 2012  Themes can and will interfere often with SLP loading depending on where in the schema it loads.

    As far as the WPML issue, that again was a change in WP codex to change to text. That was a while ago.

    On another note, anyone who does want to translate will get a free add-on or discount to new add-ons. More info on that. can be found on our new docs site. 

    #41458

    Cici
    Keymaster

    My example of what I changed and how it looks, please let me know if this is not what you are referring to. I have also attached a screenshot of my Plugin environment.

     

    • This reply was modified 6 months ago by  Cici.
    Attachments:
    You must be logged in to view attached files.
    #41466

    Mark
    Participant

    Hi Cici,

    I updated WP and SLP, I dont think my theme has any problems, if it does, what could be the issue? Just ‘Updating’ is not going to be the solution, maybe I could just make my own change to the themefiles so the problem is fixed, but you’re going to have to help me with that.

     

    Please check out the screenshots. Maybe you see something I don’t?

     

    Attachments:
    You must be logged in to view attached files.
    #41485

    Cici
    Keymaster

    Argh, (Ive written this reply  three times and keep closing my reply when I move over to your site to inspect.)

    I inspected your site and you have a lot of issues that is messing up your formatting and preventing some things loading.  See attached screenshot from your site url

    1) Loading resources, icons and images.  Did you change from http to https by any chance? Because the icons and images are trying to load from an  http location and cannot load. You are getting a 404 error

    2) I see you are using Bellard, SLP Plugin Style  that requires google font api.  That is being blocked on your site, I have no idea what is blocking it, but am guessing it is one of your other plugins or theme.

    3) You can change the directions link to read directions using CSS rules since it is in an href if need be.

    4) Have you selected English under Map/Languages.?

    5) Are you using the WP admin for multisites and have one in Dutch, another in English for those map pages?

    Finally, if all else fails : You can up load SLP Janitor (its free) and see what the settings are under Labels and clear it out from there and save. Janitor is a free add-on.

    I would  use the WP debugger ( see under Troubleshooting) and find out which one of your plugins may be creating issues for you. There is also a tutorial on how to use Firefox developer tool to find errors that need to be fixed.

    Unfortunately, we do not fix another authors/developers themes if that is what needs to be done.

     

    Attachments:
    You must be logged in to view attached files.
    #41505

    Mark
    Participant

    Hi, Thnx for quick reply.

    1. Yes I put a SSL on my domain, but It is strange because I uploaded these images after I installed the SSL. And I see the icons and images perfectly in my browser. Anyway, I uploaded them again in the media library and attached them again. Should be ok now?!

    2. Is there a way to change the fonts in Bellard?

    3. I gues this is the answer.. Do I change this in the style sheet? Any suggestions?

    4. Yes, language English was and is selected.

    5. I Don’t have multisite.

    Furthermore: installed Janitor and could delete some labels. But than they don’t translate in WPML string translation 😐

    So with this information.. any suggestions?

    #41565

    Cici
    Keymaster

    Mark,

     

    This info from the developer, and if you would be so kind as to assist, ” please ask people to help me test WPML in the base plugin while I’m developing SLP 4.5.07 this week. I’ll put out a pre-release soon.

    Quick testing and feedback wanted.  I want to push 4.5.07 public before I go offline 06/20 for a week.”

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.