JSONP Response Error

Home Forums Store Locator Plus JSONP Response Error

This topic contains 18 replies, has 2 voices, and was last updated by  Cici 8 months ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #39990

    Jill
    Participant

    I am receiving the following error after setting up the SLP widget with either the state or city selectors.

    “Store Locator Plus did not send back a valid  JSONP Response”.

    I have deactivated each of the other plugins we are currently using on the website one at a time, and none seem to be causing the issue. I  also tried activating the WordPress 2014 and 2015 themes and I’m receiving the same error.

    After reviewing the troubleshooting documentation, I just checked to ensure Ajax wasn’t being blocked and it came back  {“success”:true,…

    I’ve attached a screenshot of the plugin environment for reference.

    Do you have any other suggestions of what may be causing this error? Any advice is greatly appreciated.

     

    Thank you!

     

     

     

     

    Attachments:
    You must be logged in to view attached files.
    #39999

    Cici
    Keymaster

    Hi Jill,

    Is this a test site dev site or a production site? Could you provide the site url that has the locator page on it so the developer can check it out.   SLP 4.4.35 was supposed to have fixed any errors on this end.

     

    Oh one more thing, which order did you update the EXP pack first or the SLP 4.4.35 first? If you deactivate the SLP EXP add-on do you get any errors?

    • This reply was modified 8 months, 1 week ago by  Cici.
    #40001

    Jill
    Participant

    Hello,

    It is currently setup as a test site to get everything configured correctly.

    The url is:

    Dealers

    I updated the SLP plugin first to 4.4.35  and then uploaded the Experience zip file I had downloaded after purchase last week.

     

     

     

     

    #40002

    Jill
    Participant

    I’m not sure why the url is not appearing in the message above.

    The url is http://www.ninthfloor.ca/client/nwtestmap/dealers

    Thank you

    #40003

    Cici
    Keymaster

    Hi Jill

    I cant see the site url.  You have PhP less than 5.5 which if you had installed 4.4.34 would have sent back that JSONP ,  response, can you clear the cache on the browser you are using to test with? and then deactivate and reinstall SLP to 4.4.35, and lets see if that clears it out.

    #40004

    Jill
    Participant

    There are no errors when I deactivate the Experience add-on, just the SLP widget in the sidebar becomes inaccessible.

    #40005

    Jill
    Participant

    I’ve cleared the cache, deactivated, deleted SLP 4.4.35 and re-installed. I unfortunately am still getting the same JSONP error.

    #40019

    Cici
    Keymaster

    Hmm and only when using the Widgets in EXP? Do you have a theme tor do you have other widgets on the page besides SLP? I need as much info as possible to bump up, I could not see your site url. is it the same as the one in your screenshot of the plugin environment?

     

    #40020

    Jill
    Participant

    We are working with a custom theme however we received the same JSONP error when switching to the default WordPress 2014 and 2015 themes.

    I currently have the SLP cities widget setup in the global sidebar on its own. I also had it setup independently  in the page sidebar yesterday, but was getting the same error. I’ve included a screenshot for you of the widget setup.

    The url is the same as in my previous screenshot. http://www.ninthfloor.ca/client/nwtestmap/dealers

     

     

    Attachments:
    You must be logged in to view attached files.
    #40023

    Cici
    Keymaster

    Jill, I found it and saw the error response, I am submitting to the developer

     

    #40024

    Jill
    Participant

    Thank you!

    #40027

    Cici
    Keymaster

    No Problem, I just ran through the test, I didn’t have 4.4.08 but 4.4.07  but when I updated to 4.4.08 was able to re-create the issue as well.

    , I have alerted Lance that this is an issue, it appears to be specific to the state drop down Widget.

    Stay tuned for a fix when it is available

    #40030

    Jill
    Participant

    Ok thank you for looking into this.

    One other question as I try to find a temporary alternative solution.

    I currently have the State/Province selector on the SLP search form (not the SLP widget) setup and since there are multiple locations within Canada and the US, the provinces and states are mixed in together alphabetically in the drop down menu, which is a bit confusing.

    Is there a way to have the provinces/states listed below their respective country within the
    dropdown selector? <b></b><i></i><u></u>

    For example –

    Canada—
    AB
    BC
    MB
    NB

    USA—
    ME
    WA

    Thanks again for your assistance.

    #40033

    Cici
    Keymaster

    Hi Jill,

    First….The EXP 4.4.09 pre release is out, since you have a test site can you download and test on your site, I have done so on mine and it is fixed.

    The question about states under countries that would be possible I believe in Premier, let me double check that first, I know there was someone who was asking for that feature before, so I will get back to you on that one ok.

    #40034

    Cici
    Keymaster

    Hi Jill,

    The question about having the states appear under countries sounded familiar but it wasnt exactly the same request someone else made in the past

    That is outside the scope of the current plugin and would be a customization. You would need to send a request for a quote with the details through the Paid customization “contact us” form and include  details, specifics and the developer would give you a quote. The project start date wouldn’t be until May since he has other paid custom development projects going on.

     

    .

    #40036

    Jill
    Participant

    Ok thank you for all the information. I will download the pre-release of the Experience Add-on and give it a try.

     

    #40040

    Jill
    Participant

    The EXP pre-release 4.4.09 seems to have fixed it. Thank you for your support. Great Plugin.

    #40043

    Cici
    Keymaster

    Thanks Jill, there will be a 4.4.10 version out as well, Lance had to add something for one of our Premier customers. I don’t have the details as yet. I am happy he was able to address the issue so quickly since it is spring break and he has his son.   🙂

    If you want to help SLP improve and can take a minute to submit a rating on the WP plugin it would be greatly appreciated.  If you don’t think we warrant a five star please let us know so we can resolve it…(the WP rating reviews are  intended for the base Plugin)

    #40219

    Cici
    Keymaster

    @ Jill

    There is  a rating that reflected poorly on my support…so if you have a chance and think we (or support or the base plugin)  deserve a

     ★★★★★ rating on WordPress.org.  A huge thank you from Lance and his fellow code geeks!

     

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.