Location Not Showing Up When Searched

Home Forums Store Locator Plus Location Not Showing Up When Searched

This topic contains 23 replies, has 5 voices, and was last updated by  thinkdm2 2 years, 1 month ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #24244

    thinkdm2
    Participant

     

    I have entered, and re-entered a location into my Locations list, and when I search for the zip code, it just displays “Results Not Found.”

    Even when I search a nearby zip code, and increase the radius, other locations are displayed, but this particular location does not.

    What would prevent a single location from displaying??

    #24249

    pamburrus
    Participant

    I’ve found that certain zipcodes just dont work.  I have to type in a nearby zipcode which for me works because I’m using it for “chapters” of a club which is generalized…. for specific store locations it makes it trickier.  All I know is that on more than 2 occasions I had to use a different zip to pull a location.

    #24285

    thinkdm2
    Participant

     

    If it turns out that certain zip codes don’t work like you say, that is quite unacceptable.

    I hope to hear from a developer about this sooner, rather than later, because this issue needs to be resolved.

    #24409

    thinkdm2
    Participant

    *Bump*

    #24827

    Lance Cleveland
    Keymaster

    Zip codes do work. You need to provide more details so I can see what is going on with your site and specific location data.

    Please post a public URL as well as which zip codes are not working as you expect. Also give me some idea on what results you expect to see and why, for example zip code 91106 should return the location on E. Colorado in Pasadena CA 91106.

    Without a site URL and example I cannot guess as to what is going on with your installation. Most likely a location that is not geocoded properly or a radius setup that is too small to get a location match.

    #24868

    thinkdm2
    Participant

    Here is the URL where the locator is being used: http://www.tiamobaby.com/about/ (Scroll down until you reach the ‘Where to Buy’ section)

    When you search zip code 55343, it should turn up a result of:

    Baby Grand
    1010 Main Street
    Hopkins, MN 55343

    If you expand the search radius to 25 miles, you will see the following:

    Baby Grand
    1137 Grand Avenue
    St. Paul, MN 55105

    The 55343 location never displays, even when you search zip code 55105 and expand the search radius.

    Let me know if you need more information to resolve this issue.

    Attachments:
    You must be logged in to view attached files.
    #24884

    Kelley
    Participant

    Locations are also not showing in results on our website: http://www.trexfencing.com/find-an-installer/

    Zip Code 84606 should display CFC Fences & Decks and Fence & Deck Supply

    Also we are  having issues with map makers not displaying for categories that have been assigned custom map markers. All categories have been given a custom map marker and all locations have been assigned to categories.

    PLUGIN VERSIONS:

    Store Locator Plus 4.2.05

    Enhanced Map 4.1.02

    Enhanced Results 4.1.10

    Enhanced Searched 4.1.04

    Pro Pack 4.2

    Store Pages 4.1.02

    Tagalong 4.1.06

     

    If need to log-in to our website, please email Kelley@TrexFencing.com. Thanks.

    • This reply was modified 2 years, 2 months ago by  Kelley.
    #24887

    Lance Cleveland
    Keymaster

    When you go to Locations / Manage does this entry show a latitude/longitude?

    It should look like this:

    Properly geocoded location.

    If the numbers under the name are not there it is not geocoded and will not show up in the results.   If you have the Pro Pack you can recode that location by checking the box and using the recode selected bulk action.   If you do not have Pro Pack you can add a space after the street  address and save.  It should geocode the location.

     

    SLP 4.2.05 has a better success rate on slow networks when geocoding locations.   If you are not getting the lat/long back you may want to upgrade to 4.2.05 and try editing the address / saving. to see if the new longer wait time helps fix the issue.  If not you can go tot General Settings / Server and set your Server-To-Server speed to “Slow” and see if that helps.

     

     

    #24888

    thinkdm2
    Participant

    I had attached a screengrab of those entries with my last post.

    Lat/long displays on the far right of the row, but not under the location name and it still does not show in the results.

    #24904

    Lance Cleveland
    Keymaster

    @thinkdm2 – what are your SLP base plugin and add-on pack versions?

    #24922

    thinkdm2
    Participant

     

    SLP – v4.1.29 / SLP: Enhanced Results – 4.1.10

    #24935

    Kelley
    Participant

    The Geo Coding is working properly for all locations. Since the version update, this is when we started having problems with locations not showing in results. I’ve checked all of the plugins versions and everything is up to date. Everything was working fine until the plugin update.

    We’ve been having issues with map markers not populating on the map since we started using SLP and can not resolve why this is happening. All categories have been given a designated map marker and locations have been assigned to categories. Right now we’ve hidden the map markers since the map is not working. Please Advise.

     

    In Location / Manage, all are Geo Coded:

     

    (i.e., webpage error): http://www.trexfencing.com/find-an-installer/

    These issues with SLP are not allowing customers to find where to buy materials or find installation services.

     

    #24937

    Lance Cleveland
    Keymaster

    @kelley – PRERELEASE Enhanced Results (not for production) has been made available to the general public via the My Account downloads page.     Version 4.1.11 is the current prerelease and has been reported by several customers as having fixed the issue.   If you cannot wait for final testing and a formal production release you can download the prerelease copy, deactivate and delete your current Enhanced Results add-on on your WordPress site, add new and upload/activate the prerelease version of 4.1.11.

    If the new release fixes the problem, please post back here.

    #24940

    Kelley
    Participant

    <p style=”margin: 0px 0px 1.2em; padding: 0px; border: 0px; outline: 0px; font-size: 14px; vertical-align: baseline; line-height: 21px; font-family: Arial, sans-serif; color: #555555; background: #fbfbfb;”>@Lance – the new  PRERELEASE Enhanced Results Version 4.1.11 fixed the issues with the results not showing. All locations are populating again.</p>
    <p style=”margin: 0px 0px 1.2em; padding: 0px; border: 0px; outline: 0px; font-size: 14px; vertical-align: baseline; line-height: 21px; font-family: Arial, sans-serif; color: #555555; background: #fbfbfb;”>There are still two issues I’m trying to fix: 1) map markers not populating on the map and 2) when I try exporting data from SLP to CSV, it’s not creating a CSV doc or asking me where to save data. Please advise. Thanks.</p>

    #24952

    Lance Cleveland
    Keymaster

    @kelley – please start a new thread for each of the other 2 issues so I can track & close them separately.

     

    #24983

    thinkdm2
    Participant

    @lance—any update on the issue I am experiencing?

    #25003

    Lance Cleveland
    Keymaster

    @thinkdm2 – Have you upgraded SLP to 4.2.05 and ER to 4.1.11?

    #25006

    thinkdm2
    Participant

    I have not—was this a known issue that was actively resolved for the latest release?

    Or is this the old “restart/reboot/turn-off, turn-on” problem solving technique?

    #25051

    Lance Cleveland
    Keymaster

    ER 4.1.11 fixes several issues.

    There are new patches in ER 4.1.13 that further address various issues in the code as well as a patch in 4.2.06 that address some specific “corner cases” where a unique series of events and settings can cause problems.

    Both SLP ER 4.1.13 and SLP 4.2.06 are in prerelease and readily available to Premier Members for testing or to users that purchased those items directly from this website.

    There are code changes in ER 4.1.11 (in production) as well as 4.1.13 and SLP 4.2.05 (in production) and 4.2.05 that have fixed the issues you describe for other users.   This is not a “reboot the thing” issue of problem solving.   Issues have been located and patched in the code.   If you do not want to do this twice wait until the end of the week for ER 4.1.13 and SLP 4.2.06 to hit production.

    #25230

    thinkdm2
    Participant

    Any update on the release of the latest versions of SLP and SLP ER?

    #25243

    Cici
    Keymaster

    The current released version of Enhanced Results is 4.1.11

    The current released version of Store Locator Plus is 4.2.07

     

    A pre-release of Enhanced Results 4.1.13 is available to Premier Members for testing or to users that purchased those items directly from this website.

    #25404

    thinkdm2
    Participant

    I have updated my plugins to the latest versions, but the issue remains.

    Any other suggestions?

    #25494

    Cici
    Keymaster

    Hi Thinkdm2. I think Google is geocoding the address wrong.

    The correct geocode is Lat 44.924291,  Long  -93.413287

    But the Google API is reporting it as 37.3288733,  -87.4988727
    If you edit the location and manually enter the correct codes, it works. I tried other addresses in that zip code and they worked fine. It also works fine at maps.google.com, which is where I got the correct geocode.
    • This reply was modified 2 years, 1 month ago by  Cici. Reason: updated exact geocode
    Attachments:
    You must be logged in to view attached files.
    #25528

    thinkdm2
    Participant

    That appears to have resolved the issue.

    Thanks, Aaron.

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.