Locations Tab in admin Causes Inactivity Timeout

Home Forums Store Locator Plus Locations Tab in admin Causes Inactivity Timeout

Tagged: 

This topic contains 6 replies, has 2 voices, and was last updated by  Cici 10 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37763

    BooneSesvold
    Participant

    I am having issues with the import functionality of the Pro-pack. We have under 4,000 entries to upload that I have broken up into smaller upload files.

    Somewhere around 3,250 entries in the system, the admin stops allowing me to access the Locations tab. When I click Locations from the plugin menu, the browser spins, and eventually gives me a “Inactivity Timeout: Description: Too much time has passed without sending any data for document.” error.

    This seems really odd, considering other forum members have 15,000+ entries without issue.

    I have tried in different browsers at different IP addresses. We have GoDaddy hosting and our “Plugin Environment” is included below.

    Thanks.

     
    <p class=”envinfo”><span class=”label”>Store Locator Plus Version:</span>4.4.12</p>
    <p class=”envinfo”><span class=”label”>Pro Pack:</span>4.4</p>
    <p class=”envinfo”><span class=”label”>Tagalong:</span>4.3.03</p>
    <p class=”envinfo”><span class=”label”>Janitor:</span>4.4</p>
     
    <p class=”envinfo”><span class=”label”>This Info Cached:</span>1453134393</p>
    <p class=”envinfo”><span class=”label”>WordPress Version:</span>4.4.1</p>
    <p class=”envinfo”><span class=”label”>Site URL:</span>https://questhydro.com</p&gt;
    <p class=”envinfo”><span class=”label”>MySQL Version:</span>5.5.43</p>
    <p class=”envinfo”><span class=”label”>PHP Version:</span>5.4.42</p>
    <p class=”envinfo”><span class=”label”>PHP Limit:</span>256M</p>
    <p class=”envinfo”><span class=”label”>WordPress General Limit:</span>256M</p>
    <p class=”envinfo”><span class=”label”>WordPress Admin Limit:</span>256M</p>
    <p class=”envinfo”><span class=”label”>PHP Peak RAM:</span>49 MB</p>
    <p class=”envinfo”><span class=”label”>PHP Post Max Size:</span>33M</p>

    #37822

    Cici
    Keymaster

    Hi Boone,

    Google will only allow so many geocodes within a certain period of time that could be an issue.

    Info on General settings for optimum import.

    Other things to consider

    1)Are you on shared hosting?

    2)  Do you have a Google API?

    P.S. SLP Production 4.4.13 should be out shortly, it is in pre-release now,  once updated to 4.4.13 that should help your overall performance  (but is not specific to ProPack so I cant swear it will help your issue).

     

    #37955

    BooneSesvold
    Participant

    Cici,

    Thanks for the heads up on the SLP production release. I just upgraded to the latest version this morning. The new look and options are great. However, I am still having the same problem.

    1) Yes, we are on a shared host (GoDaddy – which I’m sure isn’t helping). I also cleared the server cache for our site.

    I thought about the Google limits too. Google only allows 2500 queries per day per IP.

    2) Yes, I have a Google API, but as geocoding quotas are not my current issue. We have no plans of paying Google to increase our quota.

    My current issue is that I am unable to access the Locations section of your plugin in the WordPress admin. I can click anywhere else in your plugin settings just fine. However, when I click the “Locations” tab, the site spins and eventually loads one of two messages:

    A)
    “503 Service Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.”

    B)
    “Inactivity Timeout
    Description: Too much time has passed without sending any data for document. ”

    We have less than 3200 locations in the system. It shouldn’t be timing out like this.

    Any insights or ideas you have would be greatly greatly appreciated. Please let me know when you have a chance.

    Thanks,
    Boone

    #37957

    Cici
    Keymaster

    Your server cannot handle the huge page size that you have set. Suggest you to use Janitor and change that setting.

    Additional Info can be found in Troubleshooting

    #37961

    Cici
    Keymaster

    If you need more info let us know, i.e. admin panel, how many locations to display on your admin panel, for instance my SLP test site locations panel is set at 10 per page in the Admin Locations display. I cant display 1000 at a time even if that is an option it will cause my server to time out.
    See the Locations Manage Page

    #38106

    BooneSesvold
    Participant

    Hi Cici,

    Thank you so much for getting back to me. That was exactly the issue. the admin was set to display  10000 (which was all of mine) and the server could not handle the display. I changed the per page display to 10 and it works fine.

    Thanks again,
    Boone

    #38108

    Cici
    Keymaster

    Boone, thanks for letting us know.  Glad it was a simple fix. I will close the post.

    P.S.If you found the support and info useful :

    If you like Store Locator Plus please leave a ★★★★★ rating on WordPress.org

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.