Map is blank and no options or locations showing

Home Forums Store Locator Plus Map is blank and no options or locations showing

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  Cici 1 month, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #43641

    Hannah
    Participant

    I got this with a theme and it was working fine.

    I added my API key and locations but now the map is blank no matter what i do.

    I also find the shortcodes confusing.

    Its set up to show on my main page but then on its own location page.

    http://www.dustyminercraftbrewery.com

    what am i missing? Also do i need a plugin to edit the look of the location details. (when it did work the text was squashed together making a really long list of stores with dead space)

     

     

    Attachments:
    You must be logged in to view attached files.
    #43692

    Cici
    Keymaster

    Hi Hannah,

    Thank you for your question and the weblink but we really need to see your plugin environment  screenshot to see what you are running for versions and add-ons.  Please refer to the Posting Guidelines

    1) I just visited your site  at that link and the map is there under the Stocklists page. Did you figure out what was going on or what exact page am I supposed to be looking at?

    2) What do you mean when you say its supposed to show up on your main page and then locations page. Do you mean you want Stores to have their own pages or load a map page, that is part of the Power Add-on.

    I do see some issues :.

    Reason 1 why your Map could be broken and wont appear on the page you want it on:

    You cannot have two Store Locator Plugins on the same site that are both using Google API Maps with browser keys.    By Inspecting your site I see you have a few WP plugins , yes one is Store Locator Plus but you also have wp-storelocator plugin with css.    Which one has the Google API key assigned to it?  Who is on first, which do you want to do the job for you?   The SLP shortcodes wont work on a page that also has another plugin that is a locator plugin that uses the Google map Javascript API

    The Store Locator Plus map (or no map) is a very visible indicator that something is wrong with the JavaScript on your site.  It is often the first thing you will notice.  Often the problem is not with the Store Locator Plus code.   Since the SLP plugin cannot control if the SLP JavaScript is run first or last there is a high likelihood that some other plugin or theme with broken JavaScript runs before it.  When that happens and /or if there is a fatal error in the other code ALL the scripts stop running on the page, including the SLP JavaScript.  That means the SLP script won’t talk to Google and that means Google won’t get the request to load the map tiles.

    #43740

    Hannah
    Participant

    So i feel like i got the above sorted out for now (i had the other plugin as yours wasn’t performing how i expected it should. (different apis but wasn’t using them simultaneously)

    there was a Jquery conflict.

    the issue in the image still stands- why does the search bar never match the map? The only what to get them in line is to manipulate the columns which i shouldnt have to do.

    I am just using the [[slplus]] shortcode.

    #43741

    Hannah
    Participant

    i will add, if i disable all plugins but SLPlus this still occurs.

    #43761

    Cici
    Keymaster

    Hi Hannah,

    It is difficult to answer you without knowing your plugin environment.   But ; what SLP style are you using and have you tried changing it?  That is the easy fix.  You can choose from over 30 of the SLP styles (see documentation) .

    If you do not like the way the results or search form or map appears you can change the layout with the Experience Add-on. Ditto if you need to use CSS.

    Your THEME , especially one that is customized , takes precedence and establishes the basic rules and style sheets over  the whole look of your site (including your locations map page)  and any built in  layouts that SLP provides as part of its styles suite can be over ridden.  So if you cannot find the SLP plugin style under your Experience/View tab (we have many, many  to select from) to best match your theme look, then you may need to use some CSS magic to override your theme. You can watch a tutorial on how to create CSS if you haven’t done it before.

    If you do want to use CSS or if it isn’t as a result of a theme then you need the Experience Add-on. 

    • This reply was modified 1 month, 1 week ago by  Cici.
    #43767

    Hannah
    Participant

    hi thank you,

     

    I am using the Brewery theme and this error has been happening on Install. I guess i will have to look into the CSS as unfortunately the add ons are just too expensive for one add on. 🙂

    I have tried every Plugin style available without it fixing 🙂

     

    #43781

    Cici
    Keymaster

    You mentioned you got this with a theme which made me look in that folder on your site.   It appears that the theme you currently have is the issue.  The theme “brewery”  is in conflict with the  Store locator Plus plugin and WP, it is using http://code.jquery.com/jquery-1.10.1.js

    SLP uses jquery 1.12 as best practices from WP dictates. Even if you rolled back to an earlier version of WP you will have issues. (See MAP BREAKING Post)

    This is also mentioned in the SLP Troubleshooting section.

    this issue will occur no matter which Mapping/locator plugin you use that is current (as far as I know).  You need to talk to the theme author about updating jquery.

    Second issue we see is with the theme CSS

    We strongly recommend using Firefox with the Firebug plugin to track down any problems with the CSS or JavaScript on your site. 90% of the problems with the map not appearing are due to either bad JavaScript prior to the Store Locator code being called, or themes that overtake all image output. The map is very image heavy using hundreds of small images from Google’s server to draw the map. If your theme does not play well with images it can override the settings we’ve built into the plugin.

    If you use the debugger or even just inspect using any Browser tool (right click and hit inspect and look under console) you have Failures on your site loading resources (images). i.e.

    . Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/uploads/2015/03/black-bones-transparent@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/uploads/2015/03/shaftman-pale-transparent@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/uploads/2016/10/Dusty-Miner-Craft-Brewery_Final-01@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/themes/brewery/img/beer1-logo@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/uploads/2015/03/3-daughters-transparent@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

    http://dustyminercraftbrewery.com/wp-content/uploads/2015/01/banner-ad_728x900@2x.png Failed to load resource: the server responded with a status of 404 (Not Found)

     

    If you fix these issues you should be back in business,

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.