Map not appearing, and no results found

Home Forums Store Locator Plus Map not appearing, and no results found

This topic contains 8 replies, has 6 voices, and was last updated by  Lance Cleveland 2 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #21871

    archerytrade
    Participant

    I just updated to the latest version (4.1.18), and the map no longer appears. Here’s what I see in the console.
    Uncaught TypeError: Cannot read property ‘InfoWindow’ of undefined slp.js?ver=4.1.18:372

    • This topic was modified 2 years, 6 months ago by  archerytrade.
    #21873

    Eddie
    Participant

    I had the same issue, and my location have started showing once I’ve unchecked the: Turn Off SLP Maps (under general settings / Google). this doesn’t make sense but it worked for me. However, my map is still only a grey block which is due to the conflict with #main in my theme, which is crazy. Still waiting for an answer from Support. Good luck.

    Jana

    #21876

    Sean
    Participant

    I have the same issue as the above mentioned posts. Blank Map and no search results. Please let us know the fix asap! This page is critical to my business as it gets 400+ hits a day!

    • This reply was modified 2 years, 6 months ago by  Sean.
    #21911

    Cici
    Keymaster

    Unfortunately, I could not replicate your issue. The technical team tests any new versions prior to release.
    Make sure your add-on versions are updated as well as the base plug-in.
    Also check that your theme is up to date and compatible, but please follow WordPress best practices regarding theme changes.

    Looking for faster forum responses? Check out the Premier Subscription. Premier forum questions are answered within 1 business day. Customers that purchased the Kitchen Sink or The Experience package can have the setup fee waived, ask for details.

    /documentation/store-locator-plus/troubleshooting/

    #21931

    Cici
    Keymaster

    /documentation/store-locator-plus/troubleshooting/#javascript_debugging

    Check out the Javascript section under Troubleshooting and if you would, please post back when an issue is resolved for others to read.

    #22166

    Paul
    Participant

    I am experiencing the same issue – example here: http://sustainableaged.org/dbtest2/

    I deactivated all my plugins to see if that fixed, but it did not. The issue started when I updated SLP earlier today.

    Here’s what I see in Firebug console:
    <div class=”errorTitle focusRow subLogRow “><span class=”errorMessage “>ReferenceError: cslmap is not defined</span></div>
    <div class=”errorTrace “></div>
     
    <div class=”errorSourceBox errorSource-show focusRow subLogRow “>
    <table class=” ” cellspacing=”0″ cellpadding=”0″>
    <tbody class=” “>
    <tr class=” “>
    <td class=” “></td>
    <td class=” “>
    <pre class=”errorSourceCode ” title=”cslmap.searchLocations(); return false;”>cslmap.searchLocations(); return false;
    </td>
    </tr>
    </tbody>
    </table>
    </div>

    #22306

    Lance Cleveland
    Keymaster

    if cslmap is not defined it is because something in JavaScript is breaking before it can load slp.js.   Look for error messages in your browser developer console.   The Troubleshooting page on this site has info on debugging JavaScript.

     

    If you are turning off Google Maps and it allows the map to display it means your WordPress theme (or another plugin)  is loading Google Maps references ON ALL PAGES even those that are not rendering a map.  That is a bad design.  The option exists, however, because not all themes/plugins are intelligent about if/when they load external scripts like Google Maps.

    #22348

    archerytrade
    Participant

    I think that this was due to an earlier version of SLP on one of my installations at releaseyourwild.com. Nothing was changed before the plugin update, but no results were showing after the update. I think I recall you changing this behavior at some point a while back(?), and unchecking Force Load JavaScript resolved this.

    #22699

    Lance Cleveland
    Keymaster

    Force Load JavaScript is not necessarily a good thing.   It is there to fix non-compliant WordPress Themes.

    All WordPress Themes are supposed to support and properly implement the wp_footer() action since version 3.1 of WordPress was released 2+ years ago.   You ONLY need to turn that on if the theme is not properly invoking the wp_footer() action.

    By using Force Load JavaScript, SLP cannot be intelligent about whether or not a page is actually rendering a map.  That means more overhead for ALL pages on your site.  In addition you lose all features that change JavaScript parameters “on the fly”.   This is typically the shortcode attributes that allow you to create different map interfaces on different pages of the site but it can have other side effects too.    In general if a user interface feature of Store Locator Plus is missing the first place to look is at Force Load JavaScript.

    I recommend that anyone using Force Load JavaScript talk to their WordPress Theme author and ask them to read about wp_footer in the WordPress Codex and implement that action hook in their theme.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.