map on store page shows error "requires api key" after upgrade

Home Forums Store Locator Plus map on store page shows error "requires api key" after upgrade

This topic contains 1 reply, has 2 voices, and was last updated by  Cici 1 year, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34729

    Mike
    Participant
    this is my code that has always worked until upgrade to SL pages 4.3.02 and SL 4.3.13
    
    [googlemaps https://www.google.com/maps/embed/v1/place?q=[storepage field=&w=100%&h=550] 
    
    this is the error:
    
    The Google Maps API server rejected your request. This service requires an API key.
    #34763

    Cici
    Keymaster

    Hi Mike,

    Two words,

    WP and Google. They changed things around. The Pages template has been revised accordingly.  On the updated page in documentation about Pages, you will see the revised shortcode, i.e.

    Here is one method for adding a map to the Store Pages template using an iframe within the template:

    There is a new shortcode that renders a direct Google Map with JavaScript if you have Pages (formerly called Store Pages) 4.3 installed.
    The 4.3 version contains some new shortcodes, in particular this one will be helpful:
    [storepage map=”location”]

    And if you were previously using the Google Map Iframe method to embed a map.  yep they require an API now.

    See the information that should assist you below:

    /documentation/store-locator-plus/add-on-packs/pao-store-pages/page-template/#google maps Iframe

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.