My locations page has gone completely wonky…HELP PLEASE!

Home Forums Store Locator Plus My locations page has gone completely wonky…HELP PLEASE!

This topic contains 8 replies, has 2 voices, and was last updated by  Cici 8 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #39809

    Gabby
    Participant

    Hi everyone, I’m fairly new to the Store Locator Plus and we had it set up through a developer. What it’s suppose to look like is when you go to the “Locations” page, two logos appear at the top for the two restaurants. You choose which restaurant (Ricky’s All Day Grill or Ricky’s Country) then you input your area and all the locations for that area will appear underneath.

    All of a sudden it stopped working. So, I went in the back end and updated the SLP plugin. Great! it changed something where text actually comes up but my logos are gone so there is no way to choose the restaurant AND the text is all unformatted.

    I NEED HELP and I don’t want to go poking around and updating plugins if I’m not 100% sure what to do. It’s just not working. Sidenote: My word press needs updating (haven’t done that yet). Could this be it? :S

    #39810

    Cici
    Keymaster

    Hi Gabby,

    In order to assist you we need more information. See Posting Guidelines,
    we need your plugin environment, a screenshot is best, your site url that your locator page is on

    The attachment you added exceeds the allowable size for posts so i cannot see what you are showing us.

    #39812

    Gabby
    Participant

    Sorry! See I’m a newbie. LOL!

    Please see screenshot for plugin environment.

    Attachments:
    You must be logged in to view attached files.
    #39814

    Cici
    Keymaster

    P.S. I was able to find the general web site for Rickys restaurants grills. Right off the bat when I inspected there was an errror message that you have included the Google Maps API multiple times and another error message about location sensor, this indicates that there is another plugin (or theme) that you have which is loading a Google Map as well or is trying to navigate using Google maps…this will break Store Locator Plus.
    start with Troubleshooting suggestions, if you do not know the other plugin that is running Google Maps then turn them off one at a time until SLP works again…that is your culprit.  Also check your themesto see if they have added some custom jquery  ( not using WP jquery).

    You can search the forum for others that may have run into issues with maps not loading etc. or you can read more about debugging under troubleshooting

    #39815

    Cici
    Keymaster

    And Yes, you should be updating and not running old versions of WP, they had security patches etc. ( see the release notes)

     

    #39816

    Cici
    Keymaster

    Find out who added this

    UniversalpixelApi

    because it also is loading a map in that function and that is causing issues,  it is really messed up. Can you turn it off? If not I would go back to your developer: (function(global) {

    if (typeof TTDUniversalPixelApi === ‘function’) {

    var universalPixelApi = new TTDUniversalPixelApi();

    universalPixelApi.init(“joog2pp”, [“r1bi0av”], “https://insight.adsrvr.org/track/up”, “ttdUniversalPixelTag83f31b5a299f4be0bccf6d840a232ecc”);

    }

    #39818

    Gabby
    Participant

    Hi Cici! I commented out the snippet of code out of the header.php that contains what you mentioned but it still doesn’t work.

    Attachments:
    You must be logged in to view attached files.
    #39823

    Gabby
    Participant

    Did I do that correctly? It should be working but still nothing.

    #39835

    Cici
    Keymaster

    The biggest  issue is coming from a plugin that is also loading GOOGLE API maps, a plugin, or your theme , is breaking Store locator Plus. You need to deactivate whichever plugin is doing that and then see if it it is fixed…I am confused by what you mean by commenting out. Are you rewriting code? Do you have a site admin  or IT person to help?

    I cant do much from this end unfortunately.   Use the WP debugger methods as mentioned in Troubleshooting.

    if you are unsure of where you have issues and need a developer to do troubleshooting on your site , you should request a support ticket to Paid support.  and provide login credentials.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.