"No Results Found" when Pro Pack plugin is activated

Home Forums Store Locator Plus "No Results Found" when Pro Pack plugin is activated

This topic contains 5 replies, has 2 voices, and was last updated by  Lance Cleveland 1 year, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26719

    Derek
    Participant

    I recently installed SLP with Pro Pack and when the Pro Pack plugin is activated I get “No Results Found” in my search results, no matter the location. When the plug in is deactivated, I can get results.

    Anyone have this issue or know a workaround? I’m currently bulk importing by having to activate/deactivate Pro Pack which over time does not seem feasible

    #26965

    Lance Cleveland
    Keymaster

    What version of Pro Pack are you using?  4.2.03?

    What is your site URL?

    Hard to guess what might be happening without seeing your problem in action.

    #27042

    Derek
    Participant

    running version <span style=”color: #000000; font-family: ‘Open Sans’, sans-serif; font-size: 13px; line-height: 19.5px;”>4.2.03</span>

    the site is : http://www.tritonwines.com/buy/

    Thanks!

    #27263

    Lance Cleveland
    Keymaster

    Can you give me an example search that does not work?

    The site is working now, but I assume you have Pro Pack disabled.  Is there a way I can see this with Pro Pack in place?

    Are you running SLP 4.2.27 now?

    #27265

    Derek
    Participant

    I am running 4.2.27 as of right now, I just activated Pro Pack and you’ll see that no matter the zip code, there are no results. For reference, 94597 is my default zip code which always generates 1 result.

    #27283

    Lance Cleveland
    Keymaster

    You are using the Pro Pack tags feature with filters enabled.  You have only with tags = “retailer” in place on that page.

    Pro Pack tags require that your location tag data and the search filters match exactly.   Uppercase/lowercase, spaces, and just about anything else will cause the tag not to match and return no results.   If you are filtering locations by categories I recommend Tagalong.  Tagalong uses the built-in WordPress taxonomy system which is a much more robust way to assign “tags” to location data than the free-form Pro Pack version.

    Option 1) remove your only_with_tag option from the shortcode, or set the Pro Pack Search Form Tag Input to NONE on the User Experience / Search Form settings (either will enforce the current tag=’retailer’ option you now have enabled).

    Option 2) tag all of your locations with the “retailer” tag.  Make sure the case matches and that you do not have errant spaces in the setting or in your tag filter set on the page.

     

     

     

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.