only_with_tag does not work

Home Forums Store Locator Plus only_with_tag does not work

This topic contains 2 replies, has 2 voices, and was last updated by  Cici 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27205

    Martin
    Participant

    Hello Support forum,

    I have some problems with the “only_with_tag” shortcode. This used to work on my site about a year ago but seems to be broken now.

    I am running an outlet search engine. The code in wordpress is pretty simple:

    <span style=”line-height: 1.5;”>[SLPLUS only_with_tag=”tommy-hilfiger” hide_search_form=”true”]</span>

    Unfortunately it does not work. The locations are tagged with “<span style=”line-height: 1.5;”>”tommy-hilfiger”, I can search for this in the backend and get all the results. No problems with spacing or capitals etc.</span>

    I have searched the forum but only found an unanswered thread with the same question:  /forums/topic/only_with_tag-not-working/

    I am running the latest version of SLP. The documentation of the tag btw is very confusing as it refers to  the google API and options which do not exist?

    Please help.

    regards,

    Martin

    #27206

    Martin
    Participant

    Hello CSA,

    I have tried to figure this out for the last couple of hours and found that the <span style=”color: #555555; font-family: Arial, sans-serif; font-size: 14px; line-height: 21px; background-color: #fbfbfb;”>only_with_tag shortcode only works when the search fields are activated. Unfortunately this does not make sense because the map will ONLY show results with the preselected tag so the search fields do not work for anything else.</span>

    In the example above the map is hard wired for tommy hilfiger stores, if a user searched for e.g. “Nike” he will get a no result error.

    I know this was working in previous version but this seems to be broken now.

    regards,

    Martin

    #27689

    Cici
    Keymaster

    Martin: Here are some things that may help:

    Be aware that you can use

    only_with_category=”category slug” if you have Tagalong enabled

    or

    only_with_tag=”tag text” if you have Pro-Pack enabled

    Check that what you are using is a tag and not a category.

     

    I see you are using hide_search_form in conjunction with only_with… I have tried this on my site, and it works. However, be aware that hide_search_form requires that Enhanced Search plugin be active, be sure it still is. If its not, and you try to use both attributes, they will both be ignored.

     

    If that does not help solve it, please post the URL of your locations page.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.