Pages Post Type Not Showing Up

Home Forums Store Locator Plus Pages Post Type Not Showing Up

This topic contains 12 replies, has 3 voices, and was last updated by  Cici 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #41406

    Cole
    Participant

    The pages custom post type is no longer showing up after the update. I have deactivated all other plugins, changed themes to the base 2016 theme and still not showing up. I have also deleted and reinstalled the SLP plugins (Base, Pages, and Pro). Any suggestions?

    #41407

    Cici
    Keymaster

    Could you please provide your Plugin environmnet?

    A screenshot would be best.  What is your site url, etc.

    Please see Posting Guidelines and recent articles.   about updates, href, jquery, WP updates etc.

     

    Also you updated what version of which  from what version?

    Did you update WP to 4.5  recently as well?

    #41413

    Cole
    Participant

    I have attached the screenshot below. Sorry about no including that in the first post. I upgraded both wordpress and SLP at the same time from the previous version.

    SLP Screenshot

    #41425

    Cici
    Keymaster

    Hi Cole,

    what does your page template look like?    We have had a few customer/developers in our Premier forum with  Pages issues a few months ago, most of the issues were theme related or they hadn’t caught the changes in the WP codex when using html and short codes.   (Lance just did some custom features  for Pages that will be included in the new Power plugin. that you may be interested in, it includes ProPack and Pages and a few other plugins and new features.  The Pages 4.4 is now  considered a Legacy add-on . I did take a look at  your site and it appeared there were some issues with the Theme layout or Contact form but I couldn’t tell you exactly what.

    I have taken the liberty here to copy  Lances response to another customer  in the Premier forum about the Pages templates and changes:

    “Are you editing each individual page and not the Page Template under the Pages tab?

    You need to go to the Store Locator Plus / Pages tab and set your template there, then go to the Locations / Manage subtab and create/recreate your pages. Keep in mind any edits you made on each individual page is overwritten.

    Read this article for assistance:
    Generating Store Pages

    Also, in Pages 4.4 there are specific shortcodes for setting the email hyperlink automatically, as well as one for a location map and website link. It is part of the default template. You may want to copy out whatever your existing template code is now to save it and then delete it (set the field completely blank) and save settings. The default page template for Pages 4.4 should be restored. It will likely have a lot of elements you want it will certainly have WordPress 4 friendly shortcode formatting without quotes.”

     

    #41429

    Cole
    Participant

    My page template is unchanged. I changed the theme to see if that was the issue and I was still unable to see the Pages post type. Before the update there would be a custom post type called pages and now that is gone.

    #41431

    Cici
    Keymaster

    I understand, Look under General/Data do you have a check box Enable pages visible to you?   The Pages custom posts was moved under General/Data for Power release.

    #41432

    Cole
    Participant

    I do not have that checkbox. I am also unable to edit, trash, nor delete pages created by SLP. From the manage location section when I click edit I get an error that states I am not allowed to edit that page.

    #41435

    Cici
    Keymaster

    Ok, I have notified the developer that this issue is occurring, we apologize, Pre release 4.5.06 SLP Can you load it and see if it comes back

    #41437

    Cici
    Keymaster

    Cole do you have a test or dev site that you can load 4.5.06 Pre release on? There was another patch and we are waiting for a customer to test it before Lance releases it for production, the more people who test it the better. Thanks

    #41449

    Cole
    Participant

    That is a dev site. So I can load it on the site in question. How do I obtain the 4.5.06?

    #41454

    Cici
    Keymaster

    SLP Pre release

     

    I tested it and it worked on my site but I have all the fancy schmancy add-ons like Power, Premier, etc… It will be released in Production tonight if no one finds an issue

    #41475

    Ryan
    Participant

    we are having the same issue. The post types are not showing in the sidebar. When I clicked edit page (under the actual location), I get a “you don’t have permissions to edit this page”

    Do we know if your latest update fixes this?

    #41482

    Cici
    Keymaster

    Hello Ryan,

    I am not sure  about the “you do not have permissions to edit this page” situation, I wasnt getting that error but then again I do not use Pages much on my web site other than to test the new Power add-on.    4.5.06 RC tested out that the Store Pages icon on the Admin Sidebar does reappear.   If you have another question or the update created a new issue could you please let us know or start a new thread. Appreciate it.

     

    CiCi.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.