Press Permit and Tagalong

Home Forums Store Locator Plus Press Permit and Tagalong

This topic contains 10 replies, has 3 voices, and was last updated by  Steven 1 year, 10 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #23002

    Steven
    Participant

    Hi

    Has anyone had experience in using Press Permit the Tagalong plugin?

    http://presspermit.com/

    I created a Role and assigned the specified capabilities for that user. This user is to add Store locations, everything works fine except the tagalong field is greyed out in the Add or Edit page. This user can happily create new locations and see the Tagalong boxes, however you cannot select them.

    Looking at the roles, to have the Tagalong fields editable you need to have the option “pp administer content” selected. However this allows access and editing to everything the user should not have access to (Pages/Posts/Themes/Plugins/etc).

    I have tried adding capabilities to PP (tagalong_slp / pages_slp / slp_manage_locations_action (I started guessing at this point)) as dedicated roles, but this does not work either.

    If anyone would be able to point me in the right direction I would appreciate it!

    Thank you

    #23078

    Steven
    Participant

    I’ve now tried these other ones attempt to enable this, but so far nothing.

    create or edited stores
    edited stores
    locationtaxonomy
    manage capabilities
    pages slp
    renderpage taglist
    slp editform section
    slp locationinfoform
    slp manage locations
    slp manage locations action
    slp storepage attributes
    slp storepage features
    slp storepage labels
    slp tagalong fields
    store categories
    store page
    storepage attributes
    storepage features
    stores
    tagalong slp
    tax input
    taxonomy

    Looking at how it is coded, Tagalong should come under the same permission as ‘manage_slp’ if I am reading it correctly.

    Pro plugin, Social options on the edit page work fine and they are editable in both Admin and Sub Admin user logins. It is just Tagalong plugin that is having the issue.

    I really hope someone out there can point me in the right direction, I’ve spent two days on this now and I’m pulling out my hair! Thanks

    #23215

    Steven
    Participant

    I give up. I have tried everything that I can think of, I have gone through the code these past few days so much my eyes have crossed and tried to brute force the permission for the Tagalong field

    I understand that this is having issues with another plugin. However the other plugins I have installed that extend the edit/add screens (Pro and Social) do not behave like this at all.

    Disabling “pp administer content” seems to add disabled=disabled in the input line for each of the fields.

    I would assume Tagalong would fall under the role of manage_slp or manage_slp user as the others do so that it is editable. However it does not which causes this issue.

    Personally I think this would be classed as a bug as Tagalong does not follow the same permissions as the others, but I understand that this (if a bug) will be low down on the list of priorities as it is just one user experiencing issues with a third party plugin. However, Lance if you read this, I would be grateful to add it to your list to look at sometime in the future if you get a chance. Thanks

    #23454

    Cici
    Keymaster

    Steven,
    Store Locator Plus has a roles and capabilities add-on called User Managed Locations.

    /product/slp4-user-managed-locations/

    Read the documentation and the release details to see if this might serve your needs better. Other third party plug-ins might not work as well with SLP.

    /documentation/store-locator-plus/roles-and-capabilities/

    #23534

    Steven
    Participant

    CiCi, thank you for your response

    I am NOT trying to secure or lock down any capabilities of Store Locator, it has done it itself and I’m trying to get it so it is not restricted.

    The Plugin I’m using to secure unrelated and sensitive pages, as well as WP admin for other admin (as they are idiots and poke around). The plugins I am using is Press Permit and its additional plugin Capability Manager Enhanced.

    As a side effect of using this plugin it has locked out the Tagalong option in the SLP Add or Edit Location page. This I do NOT want to happen as it is stopping other Admins, who have access to SLP, from fully creating or editing locations.

    Social and Pro Pack are not affected by this and work as they should. Tagalong fields are set to hidden when the page loads and I cannot stop this from happening. Purchasing another Addon for locking down SLP would not make any difference imo as the same issue will occur.

    Because the behaviour is different between Pro/Social and Tagalong it makes me believe that Tagalong has not been assigned a role like the others and I have, after searching the code for days, not found this as it goes beyond my abilities at the moment.

    Thank you for your help so far

    #23563

    Lance Cleveland
    Keymaster

    I will look through Tagalong and see why the roles & caps are different for those menu items than the others.  They should be the same.     I’ve got a lot on my plate at the moment so it make take a bit of time.

    Default settings for SLP:

    If a user has role “administrator”  and they do not have the “manage_slp_admin” capability they are assigned these capabilities:

    • manage_slp
    • manage_slp_admin
    • manage_slp_user

     

    #23564

    Steven
    Participant

    Thank you Lance, all three show up in Press Permit roles under the role assignment. Even if all three are ticked Tagalong is greyed out (hidden assigned to the html tag).

    Only by enabling “pp administer content” which unlocks everything allows the tick fields to work.

    No rush, it’s currently just an annoyance as once another admin edits or creates I have to go in and do the tagalong. I know its a compatibility issue with a third party plugin, so if you do get a chance I would appreciate it, if you don’t I understand. Thank you

    #26971

    Lance Cleveland
    Keymaster

    I know this is an old post, but I am finally doing some related roles & caps work and Tagalong updates.   The latest version (4.2.01 of Tagalong / 4.2.23 of SLP) seem to be working as expected with Press Permit.

    #26972

    Lance Cleveland
    Keymaster

    Nevermind – found the problem.  The menu was accessible but the deeper category management issues was not working.   This will be fixed in the next SLP release 4.2.24.

    #26989

    Steven
    Participant

    That is great news, thank you Lance!

    #27207

    Steven
    Participant

    Sorry to trouble you Lance, I’ve got round to updating and testing everything and sorry to say it is not working still.  Tried using the Pre production Tagalong too to no avail.  Options are still greyed out

    – SLP v4.2.25
    – Tagalong v4.2.02

    – Press permit core v2.1.51
    – Capability Manager Enhanced v1.5.2

    Custom role – Sub Admin has both Manage SLP and Manage SLP User ticked.
    [Permissions > Role Capabilities > Create New Role : Sub Admin – Then assign appropriate roles]

    Incidentally after these updates Manage SLP Admin now no longer appears as an option, even if you try adding it it reports added however does not appear.  This was an available option previously.
    [Permissions > Role Capabilities > Additional Capabilities]

    Please let me know if I’m doing something incorrect.  Thank you

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.