Results not displaying

Home Forums Store Locator Plus Results not displaying

This topic contains 9 replies, has 4 voices, and was last updated by  Lance Cleveland 2 years, 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #22392

    Allan
    Participant

    Plugin works perfectly in Safari, however, when searching in Chrome or Firefox, the results are not being displayed on either the map or below. I have the latest updates of both the plugin and pro-pack, and am not “force-loading” JavaScript.

    http://ideamonix.net/rcot/where-to-sell

    #22448

    Allan
    Participant

    I’ve learned from a bit of debugging that the plugin functionality (search & results) are only being displayed for logged-in users, not everyone. How can I address this?

    #22490

    Bobby
    Participant

    Same here. Only logged in users can see results. Otherwise the locator pin just moved to the search result and no results are displayed, on the map or in the list.

    #22527

    Cici
    Keymaster

    Allan,

    I just opened your site in my browser using Google Chrome.  When I typed in a zip code and  I wanted to do a search my pop-up from Google was asking if I wanted to allow my location to be shared with RCDOT.  Once I clicked  “allow ” I was able to see a map.  Of course since I am in Charleston SC it showed me Charleston area so  with  my address  zip code it reflected no results found.. BUT when I typed in a Texas zip code, for instance 73301 I saw the map with all the locations.  I am not a member and was not “logged in” as one so I assume the issue is with the users default settings for privacy.

    Based on this quick, non techie type search ,  I am wondering if your users may be experienced same issue, i.e. they have a setting in Chrome or Firefox that is to keep  sites from using the users location  private….and /or tell me if a site is using my location.

    “Google Chrome may use web services to improve your browsing experience. You may optionally disable these services.”

    #22536

    Bobby
    Participant

    Thanks Cici for the feedback. I disabled the option in the store locator plugin, cleared cache on the server and my browser and still the same issue. The map is showing up but no results. I just tested it on the dev server and it was not working there either so I don’t think this is a result of the move.

    #22557

    Cici
    Keymaster

    Hi Bobby,

    Which move are you referring to?    Did you try the suggestions  under  troubleshooting?

    /documentation/store-locator-plus/troubleshooting/#javascript_debugging

     

    There is also a debugging tool.

    /product/debug-my-plugin/

     

     

    #22563

    Bobby
    Participant

    Moving from the staging site to the live server. We built this on one domain and moved it once it was approved. No issues with anything else, just this plugin. I am getting an error in the console “SLP server did not send back a valid JSONP response for csl_ajax_onload.” Again, this only happens when I am not logged in as an admin. If I am logged it, all works just fine without errors. This is the strangest thing.

    Here is the link if you want to take a look: http://thedr.com/find-a-certified-gluten-practitioner/

    Thinking it might be a javascript issue, I disabled all plugins, same result. I removed jquery from the site, same result. The only thing that seems to work is changing the theme. I can change to Twenty Fourteen theme with all plugins activated and it works not logged in. This leads me to believe there is something in the theme but I cannot narrow it down any further.

    #22701

    Cici
    Keymaster

    Bobby, Did you look under the Advanced topic, Trouble shooting for javascript and/or Known Conflicts?

    /documentation/store-locator-plus/troubleshooting/#javascript_debugging

    /documentation/store-locator-plus/troubleshooting/known-conflicts/

     

    sorry I cant be of more help. There are sometimes problems with themes. Perhaps you can work with the theme developer in WordPress. Lanc has published  some blogs along those lines as well.

    #22702

    Lance Cleveland
    Keymaster

    This could be part of the problem as well:

    Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.
    0
    Password fields present in a form with an insecure (http://) form action. This is a security risk that allows user login credentials to be stolen.
    0
    SecurityError: The operation is insecure.
    if(sheets[sheetIndex].cssRules || sheets[sheetIndex].rules){
    
    
    
    I am trying to get debugging output to come up on the site but I am not seeing any due to the pre-existing JS errors in other plugins/scripts.
    #22703

    Lance Cleveland
    Keymaster

    I am seeing a “cslmap is undefined” error, which means that the JavaScript stack is corrupted before slp.js can be properly loaded.

    You can try turning on “Force Load JavaScript” under the SLP General Settings tab.  That will pre-load SLP.js earlier in the JavaScript stack.  However you will be better off fixing the other JavaScript errors and ensuring your theme works with wp_footer() in the long run.  There are multiple blog posts on the topic.  You lose functionality and performance when that feature needs to be enabled.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.