Show Locations At Startup not working

Home Forums Store Locator Plus Show Locations At Startup not working

This topic contains 7 replies, has 2 voices, and was last updated by  Cici 2 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #43086

    Julien
    Participant

    Hi,

    Show locations at startup is not working.

    I’ve set up the Google Map Api Key, entered my locations…but nothing appears on the map

    <span style=”color: #a3aaae; font-family: proxima-nova, ‘Helvetica Neue’, Helvetica, Arial, sans-serif; font-size: 15.6px;”>http://bit.ly/2cc8DCn</span&gt;

    Plugin 4.6

    Can you please help ?

    Thanks

    #43112

    Cici
    Keymaster

    to better assist you , please provide your plugin environment per posting guidelines

    what are you trying to show us here?

    Refer to the documentation. for guidance on how to set up your page to display your map.

    The Troubleshooting Guide also provides tips

    #43142

    Julien
    Participant

    Hi,

    Here’s the plugin environment

    Store Locator Plus : 4.6

    WP : 4.6.1

    Website :http://www.krav-maga-global.fr/
    <p class=”envinfo” style=”font-size: 15px; line-height: 1.7; margin: 0px; color: #444444; padding: 0px; font-family: sans-serif;”></p>
    I’ve’ set up everthing to make the locations appear directly on map without typing any city.

    I’ve entered my API Key but on my webesite page, there a box appering saying that the website needs an API Key… (see enclosed) and nothing appears on map.

    You can view the page of my website here .

    Can you pleqse help ??

    • This reply was modified 2 months, 3 weeks ago by  Julien.
    Attachments:
    You must be logged in to view attached files.
    #43181

    Cici
    Keymaster

    You apparently never enabled or activated the key in your project. delete the key from the SLP General/server/

    Go into your Google Developer console project to obtain the correct api key. Here are the directions on our Docs site , follow the steps exactly.  Do not restrict your IP or domain (see Step 3)

    Using simple “Inspect” in Chrome you can see the exact  error message with the links  to the google error message page.

    js?language=fr&region=FR&key

    Google Maps API error: ApiNotActivatedMapError https://developers.google.com/maps/documentation/javascript/error-messages#api-not-activated-map-error_.ib @ js?

    (if you use the Browser developer tools and follow the error link, brings you to this page.

     

    ApiNotActivatedMapError Error

    The Google Maps JavaScript API is not activated on your API project. You may need to enable the Google Maps JavaScript API under APIs in the Google API Console.

    See Obtaining an API key.

    #43188

    Julien
    Participant

    I’ve done that.. map is showing but not with my locations at starting (it says no locations found)

    It only works when i add a city in the search field. Why can’t all my locations appear directly on map ?

    Trouver un club de krav maga KMG

     

     

    #43199

    Cici
    Keymaster

    What are your settings under RESULTS? Besides Show Locations at Start up? For instance I have these settings to maximize results

    ??
    ??

    Under EXP/Search what are your settings?

    Mine are:

    mi
    ALWAYS USE

    Under Map, what have you selected for destination markers? There seems to be an issue with the GET markers from Google. Also do you have your Center map at and Zoom settings correct.

    If you are using special markers make sure you have the correct file path.

    Use the Debugging  tool as shown in Troubleshooting

    #43213

    Julien
    Participant

    Everything is settup as you said. Can I please give you my credentials so that you can check what happens ??

    #43237

    Cici
    Keymaster

    Use the troubleshooting guide,

    You have a Plugin that is also using Geocode functions in the search. Follow the instructions for debugging in Troubleshooting, the easiest one is to deactivate  your Plugins one by one. There is a whole section that tells you what can interfere with your map.

    Plugin called  Event Manager , deactivate and see if map works ..if you look at the css in the EM plugin you will see it has reference to geocode.

    http://www.krav-maga-global.fr/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.6624

    On your Main site I saw failed to load resource

    FAILED TO LOAD RESOURCES ERRORS that were directed to your Wp theme AVADA.

    The link you provided, is that a Dev site or  production site? because google apparently does not think you have an API Key. You cannot switch from Dev site to Live production site  and copy over all the data from WP seamlessly, also  if the key you are using is a geocode key, that is not the correct key to use for SLP, you need the MAPS API Javascript key

    Anything more than what I’ve provided for tips and suggestions is not my forte. You can ask for Support through the Paid support option, I do not log into other peopls sites, that is something you would need to order through paid support an the developer would look into it.

    or if you need help with your WP Site in general, visit cybersprocket labs.com

     

     

     

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.