Autocomplete zip code

Home Forums Store Locator Plus Autocomplete zip code

Tagged: 

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 11 months, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #36900

    Hendro
    Participant

    The Append feature wasn’t working for me before. But I’ve just tested it using a different browser and it’s working fine! Progress! It maybe just some cache problem on the previous browser.

    Thanks for that!

    OK so on to next problem, the autocomplete. Can you see why this is not working?

    • This topic was modified 11 months, 3 weeks ago by  Cici.
    • This topic was modified 11 months, 3 weeks ago by  Cici.
    #36919

    Cici
    Keymaster

    @ Hendro

    It does work, At least it does on mine, I tried all different combinations of settings, even changed the search layout and it suggested zip, I found that if I typed too fast it didn’t work as fast as I typed. The computer needed time to think and for the drop down to load with suggested zip codes.

    Provide your Screen shots of the Experience Search tab settings. I cannot replicate the issue so I need to see if I can recreate it

    • This reply was modified 11 months, 3 weeks ago by  Cici.
    • This reply was modified 11 months, 3 weeks ago by  Cici.
    #36925

    Hendro
    Participant

    Hi Cici,

    Sadly hasn’t worked on mine. Not matter how slow I typed. And I’ve used different browsers on different computers this time, mac and pc.

     

     

    Thank you.

     

    #36931

    Cici
    Keymaster

    Hendro,

    1) Can you attach a screen shot of your experience/Search settings?

    2) What SLP Plugin Style are you using?

    3)Did you refresh after updating?

    4) Do you have location sensor off or on?

     

    #36942

    Hendro
    Participant

    Hi Cici,

    I’ve attached the screenshots of the settings as you’ve requested.

    Not sure what you meant with refresh but I did try the search on different computers that have never been used for this before.

    • This reply was modified 11 months, 3 weeks ago by  Hendro.
    Attachments:
    You must be logged in to view attached files.
    #36977

    Cici
    Keymaster

    Ok @ Hendro So now we should be able to communicate on this subject here.
    I started looking at your http://www.stoneworld.com.au/store-locator
    site. When I click on your search box I see this

    #36979

    Cici
    Keymaster

    I see the<input id=”addressInput” class=”ui-autocomplete-input” autocomplete=”off” name=”addressInput” size=”50″ type=”text” value=”” placeholder=”” />

    #36981

    Cici
    Keymaster

    @ Hendro

    So I now have had the Developer, Lance troubleshoot what we could from our end without logging into your site. He also cannot figure out why your autocomplete is broken, but he has run a test and keeps getting back results under the zipcode, i.e. THAT is broken…. it returns 0
    It should always return something like []
    Usually with postal/zip in the middle [“2001”,”2002”]

    Lance replied to me”something on his site is blocking the standard (and very simple) SQL query to look up postal/zip codes.    The AJAX listener is running but something is preventing the SLP code from running for Enhanced Search.  Everything looks normal from the outside.

    Go to our troubleshooting page, turn on the debugging/debug log stuff and  try surfing here:

    http://www.stoneworld.com.au/wp-admin/admin-ajax.php?action=slp_list_location_zips&address=2

    Then turn off the debugging settings.

    We can then look at his debug.log file that would be created in his wp-content directory for any blatant PHP errors.”

    As mentioned I reset all my settings to match yours exactly and it works (see attached)

     

    Attachments:
    You must be logged in to view attached files.
    #36983

    Hendro
    Participant

    That is very strange Cici.

    As you can see from my screenshot, the autocomplete is turned on and set to Zipcode.

    Anyway I have done as you’ve asked and this is the result of that page:
    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scriptsadmin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/stondcom/public_html/wp-includes/functions.php on line 3787

    [“2007″,”2010″,”2015″,”2018″,”2021″,”2025″,”2026″,”2032″,”2039″,”2040″,”2042″,”2044″,”2045″,”2047″,”2048″,”2049″,”2063″,”2064″,”2065″,”2067″,”2068″,”2075″,”2077″,”2092″,”2093″,”2099″,”2100″,”2103″,”2113″,”2117″,”2124″,”2131″,”2132″,”2133″,”2136″,”2141″,”2142″,”2144″,”2145″,”2147″,”2148″,”2150″,”2151″,”2152″,”2153″,”2154″,”2155″,”2161″,”2162″,”2163″,”2164″,”2166″,”2170″,”2177″,”2190″,”2191″,”2192″,”2193″,”2194″,”2196″,”2200″,”2205″,”2207″,”2210″,”2211″,”2212″,”2224″,”2227″,”2228″,”2229″,”2232″,”2250″,”2260″,”2261″,”2263″,”2282″,”2283″,”2292″,”2293″,”2294″,”2298″,”2315″,”2316″,”2320″,”2322″,”2323″,”2324″,”2325″,”2333″,”2337″,”2340″,”2350″,”2360″,”2370″,”2372″,”2380″,”2390″,”2400″,”2428″,”2430″,”2440″,”2444″,”2445″,”2450″,”2460″,”2464″,”2470″,”2477″,”2478″,”2480″,”2481″,”2484″,”2486″,”2487″,”2500″,”2502″,”2505″,”2518″,”2519″,”2526″,”2527″,”2529″,”2533″,”2541″,”2560″,”2567″,”2580″,”2609″,”2620″,”2640″,”2641″,”2646″,”2650″,”2705″,”2720″,”2749″,”2750″,”2756″,”2759″,”2760″,”2770″,”2780″,”2790″,”2800″,”2830″,”2850″,”2911″,”3012″,”3023″,”3029″,”3032″,”3042″,”3062″,”3072″,”3121″,”3132″,”3162″,”3201″,”3205″,”3207″,”3215″,”3220″,”3222″,”3250″,”3280″,”3502″,”3620″,”3632″,”3722″,”3820″,”4022″,”4120″,”4121″,”4123″,”4127″,”4129″,”4172″,”4207″,”4211″,”4212″,”4213″,”4214″,”4215″,”4217″,”4218″,”4219″,”4220″,”4227″,”4720″,”4802″,”4825″,”4852″,”5211″,”5253″,”5291″,”6021″,”6027″,”6062″,”6172″,”6210″,”6220″,”6230″,”6258″,”6280″,”6312″,”6722″,”6725″,”7250″,”821″,”9726”]</span>

     

    By the way, this page (and only this page from your forum) is still loading weird for me. I can’t click on any attachments…

     

     

    • This reply was modified 11 months, 3 weeks ago by  Cici.
    Attachments:
    You must be logged in to view attached files.
    #36990

    Cici
    Keymaster
    The developer and I both tried to re create your issue and couldn’t, but he said our add-on Enhanced Search (ES) does not use the wp_enqueue_style() method and I’m guessing if you  look at the call stack that led to it (that error)  then it is another plugin that is not doing it correctly and breaking AJAX.


    :47
    ]

    If it was SLP or ES we would see that warning EVERYWHERE. But we have not had any people complain about it, occasionally someone comes up with one thing that is quirky , but with so many users combining so many plugins it is impossible for us to check  and recreate any issues. You can try turning off plugins one at a time or all and check to see if autocomplete works, until you get to the one that broke the site if you arent comfortable with finding which one sues the WP enqueueu 
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.