Split:zoom map markers on location

Home Forums Store Locator Plus Split:zoom map markers on location

Tagged: 

This topic contains 6 replies, has 2 voices, and was last updated by  Cici 4 months, 4 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41527

    Francisco Carlos
    Participant

    Hi Cici,

    I’m afraid I hijacked this thread, as my question is not the really the same as the original. If so, please move it to a new thread.

    Sorry for not sending my environment before.

    The map url: http://beharradaukat.eus/eu/

    The map is used by people living with Crohn’s disease or ulcerative colitis who urgently need accessing washrooms when they are away from their home. You can find a similar one at : http://www.go-here.ca

    I need to show the current location in the map at a selected zoom , get all markers and put them in the map. Markers close enough to the current location will be shown without the map zooming. Markers which are farther, will be shown when I zoom out.

    Could you tell me what do I need to have it working in that way?

    PD: I can’t find the “disable initial directory” option. It’s included in the Pro Pack?

    Kind regards,

    Francisco

    • This topic was modified 5 months, 3 weeks ago by  Francisco Carlos.
    • This topic was modified 5 months, 3 weeks ago by  Francisco Carlos.
    • This topic was modified 5 months, 3 weeks ago by  Cici.
    Attachments:
    You must be logged in to view attached files.
    #41552

    Cici
    Keymaster

    Hi,

    Thank you for providing the information.

    It appears all your locations are centered around the northern area of Spain on border of France is this correct?   Do you have locations all over the world on this site? If not I would lower that results radius to a lower number under Experience/results.

    It appears  you have the results  default radius as  this.default_radius = 40000;  Is there a reason to set it this high if all your locations are within a few hundred km?

    As far as the search radius. I see that you have some very low number for KM to search by in the drop down menu, yet your default is 10km. If urgency and closest to them is more important that I would set the default search radius to one of your lower number, per haps 0.5km??

    (BTW it appears your lower numbers for km have a comma, i.e 0,500 not a period so it is not showing up as .5 km. Maybe it is just my eyesight

    I would have set the lowest number or something in between like  1km as the default for the drop down search default and then adjust the zoom level accordingly.

    You do not have a label in the search form box. what are site visitors supposed to enter in the search form box?  City, or zip code or address or any text? For instance I went to your site and entered Barcelona and no results found.  Or  is the search form box supposed to be tags in free form text? I see you have Pro Pack so it could be by tags, or if you do not have tags is it supposed to be search by an address?  Or do you want them to not see that search form at all? If you want to hide that search form box and only see radius, the hide  search form box is part of the Experience add-on or Legacy Enhanced search

    I have attached a screenshot of a set up for default radius 1km with options of 0.5 and so on. When I entered a zip code the map zoomed in around the locations based on whatever I chose to search for in the radius, If 0.5 km it would zoom even closer

    if you DO NOT want to autozoom after the search there is a do not auto zoom setting (Use only the “zoom level” setting when rendering the initial map for show locations at startup. Do not automatically zoom the map to show all initial locations.)

    But that is part of the Experience Add-on or Legacy Enhanced Map add-on

    2) Sorry I didn’t know what you had installed:  Disable initial directory is part of the Experience Add-on or the Enhanced results legacy add-on.

    Here is our new  documentation site  if I didn’t explain or provide you what you are looking for. You can also find a link to tutorial videos and demos site

     

     

     

     

     

    #41553

    Francisco Carlos
    Participant

    Hi Cici,

    Thank you very much for your suggestions. I was testing different values whether it made a change.

    I will check the Experience Add-on and its  “do not auto zoom” setting.

     

    Kind regards,

    Francisco

    #41554

    Cici
    Keymaster

    No problem,

    You can play with the Demo as well, just keep in  mind the demo site also has Premier installed I believe, but it is clearly marked in the UI  in teh various panels which features are available as part of the Experience Add-on, the Power add-on or Premier.

    As a side note, SLP actually had a customer who had find a rest room using SLP. I cant recall the name of the customer but it is possible Lance knows.

     

    Good luck!

     

     

    #41979

    Francisco Carlos
    Participant

    Hi Cici,

    I’ve just tried the demo site and I’m not able to get working the location sensor. I have enabled ‘Use location sensor’ at General -> User interface but I do not get any prompt and the ‘home marker’ stays at the center of my country.

    Some related bugs I found:

    • About the markers: at the demo site the default markers are missing, there is a message at the admin about that.
    • ‘Hide Home Marker’ option at ‘Experience -> map’ remains ticked when traying to disable it (you can see it going to another section and coming back)
    #41981

    Francisco Carlos
    Participant

    … and having  ‘ Show Locations At Startup’  enabled  and ‘ Do Not Auto-zoom’ disabled’  still zooms the map to the maximum to show all the locations

    #41995

    Cici
    Keymaster

    The demo site will be updated with any  fixes with version SLP 4.5.08.    The demo is not going to give you a location sensor to speak of.

    This is how Location sensor works and it is totally dependent on your browser.  Try it with Firefox. Chrome is picky abut whetehr or not to ask you (unless you  are a secure site)

    I have Experience add-on 4.5.08 installed and Do not aut0 zoom works perfectly.

    You need to look at what your initial radius settings, default radius settings  are under the results as  well as the  “center map” at.

     

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.