store pages map not displaying with shortcode

Home Forums Store Locator Plus store pages map not displaying with shortcode

This topic contains 18 replies, has 3 voices, and was last updated by  Cici 10 months, 4 weeks ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #37134

    Mike
    Participant

    After upgrading to PAGES Version 4.3.02 and SLP Version 4.4.05 the map shortcode stopped displaying the map on the store page.  example located here http://www.becomeavolunteerfirefighter.org/departments/excelsior-fire-co/

    the map was displaying below the image and when using the inspector I can see the map container but no map displays.

    what is the fix for this?

    #37140

    Mike
    Participant

    I tried the force JavaScript and now the map displays, but I never had to do that before so I am not sure what the issue may be.  Any ideas??

    #37151

    Cici
    Keymaster

    Oh no you shouldnt have to do that at all.

    Did you Upgrade WP recently or at same time and did you update any of your themes? Did you upgrade ProPack to 4.4 as well? If not you should…

    The Force Javascript was a work around for some old themes that were not using the WP best practices, Excerpt from the Troubleshooting guide :

     

    If you have this box checked , all kinds of crazy things can happen and Store Locator Plus settings may not work properly on your site. Even things that seem unrelated. One such instance this developer discovered; When the radio button is checked “Force Load Javascript”, your Results order will not work properly, even if you have the Enhanced Results add-on pack. In most instances you should never check this box. The reason it exists at all is to compensate, as a work around, WP themes that do not follow best practices or are poorly designed. It is a work around, not intended for general use. Having this box checked can effect SLP add-ons, such as Pages, Enhanced Results and other features. When you first check the box off, a warning message will appear. Subsequently the message will not keep popping up. Check under General/User Interface for more information.

     

    #37152

    Cici
    Keymaster

    P.S. Mike can you provide a screenshot of your Plugin Environment?

    #37153

    Cici
    Keymaster

    There is a video about the changes and the PAGES  template changes due to the changes in WP. So that could have had an impact on your site.    If you had not seen the info and news release about the changes in Page Template set up and how to get the Google map instead of an Iframe (static map) you may want to review them here so that you do not need to have  Forceload javascript

    Short Video On pages 4.3.02

    May have been because you forced load javascript but saw these error messages” at your site see ”

    // Our map initialization

    //

    if ( jQuery(‘div#sl_div’).length ) {

    if (typeof slplus !== ‘undefined’) {

    if (typeof google !== ‘undefined’) {

    slp.setup_helpers();

    slp.setup_map();

    } else {

          jQuery(‘#sl_div’).html(‘Looks like you turned off SLP Maps under General Settings but need them here.’);

                    }

    } else {

    jQuery(‘#sl_div’).html(‘Store Locator Plus did not initialize properly.’);

    }

     

    #37154

    Cici
    Keymaster

    There is a video about the changes and the PAGES  template changes due to the changes in WP. So that could have had an impact on your site.    If you had not seen the info and news release about the changes in Page Template set up and how to get the Google map instead of an Iframe (static map) you may want to review them here so that you do not need to have  Forceload javascript

    Short Video On pages 4.3.02

    May have been because you forced load javascript but saw these error messages” at your site see ”

    // Our map initialization

    //

    if ( jQuery(‘div#sl_div’).length ) {

    if (typeof slplus !== ‘undefined’) {

    if (typeof google !== ‘undefined’) {

    slp.setup_helpers();

    slp.setup_map();

    } else {

          jQuery(‘#sl_div’).html(‘Looks like you turned off SLP Maps under General Settings but need them here.’);

                    }

    } else {

    jQuery(‘#sl_div’).html(‘Store Locator Plus did not initialize properly.’);

    }

     

    #37161

    Mike
    Participant

    I have the screen shot of all plugins attached. wordpress is at version 4.4

    I tried deactivating all plugins except SLP and Store Pages then I enabled the 2016 theme, but the maps still will not load.  all plugins have been updated to the latest versions.

    the theme I am using is TOTAL and it follows all current standards.

    I am using the following shortcode [storepage map=”location”] and this has worked before but after the latest SLP upgrade it seems to fail unless force javascript is enabled.

    I currently have Force  Load Javascript off.

     

    Attachments:
    You must be logged in to view attached files.
    #37167

    Mike
    Participant

    I am not sure I understand that error you are referring to.  Is that an error you are seeing on my site?  Is that something wrong with my environment?

    Mill Creek

    I am using the updated shortcodes as shown in the video you provided.

    here is another screen shot of the plugin environment attached.

    Attachments:
    You must be logged in to view attached files.
    #37178

    Mike
    Participant

    after disabling all plugins and switching themes it still does not work and I get the error below.  I am out of options at this point and it seems like a bug or a setting that I am missing.

    TypeError: slplus is undefined

    #37180

    Cici
    Keymaster

    Hi Mike, I see you have WP Google Maps installed. ANY map plugin or theme with built-in maps can interfere with SLP, but usually just when rendering the map.

    There is a setting on the general settings page that allows you to turn off the built-in SLP maps with Google.

    However we cannot guarantee that the OTHER plugins are loading the RIGHT VERSION of Google Maps JavaScript API V3 when you do that.

    Some mapping software (not ours) forces an old version of Google Maps to be used because their stuff breaks with the newer maps interface.

     

    If the other plugins/themes are well-written they are using the latest production release and everything should be OK even if you turn it off in SLP.

    Also make sure your Plugins, especially themes are using a later version of jquery. 1.11 and above preferably.

    Let us know what you find out and if this info helped.

     

     

     

    #37185

    Mike
    Participant

    I deactivated WP Google Maps and the map still does not display.

    I disabled all plugins except SLP and the map did not display.

    I switched to 2016 theme with all plugins disabled and the map did not display.

    I removed SLP and uploaded a fresh install via ftp – maps do not display.

    only works if I force load javascript.

    see this page where map does not display:

    Mill Creek

    #37187

    Cici
    Keymaster

    Hi Mike,

    Didnt see the link in your above post where the slp locator page url would be found this the link

    Departments Involved

    Under the Troubleshooting Guide, there are some simple tests and also Debugging instructions if you want to look into it..

    Troubleshooting

     

    I have also added this post on our support board.

    The suggestions I ran by you came from the developer.  If you download a 4.3.  version of SLP before it went to 4.4 were you still having problems? Did you jump updates or change domains or hosts or servers?

    Trying to get an idea of what could have happened in the interim on your site since I am having difficulty recreating your issue and am testing some newer updates to SLP atm. (we are getting ready to release 4.4.08)

    P.S The error I posted above , yes was from your site,  that is where the jquery was coming back with errors, and slp undefined and that was before you changed anything new .

    We did see some issues when everyone (Wp plugin authors and users) was updating to WP 4.3 at same time SLP updated and they found there were some issues with some themes or other plugins loading their jquery versions  first and thus breaking the SLP Map.

    The Info blog about it is here if you want to look at it

    If none of the above gets you to the root and resolution of the issue and you are happy with the way it looks now then we will need to get back to this at a later date. Thanks

     

     

    #37199

    Cici
    Keymaster

    Under the documentation

    Pages Template and FIeld name attributes

    reference about using Google iFrame..  More Info about that here

     

    #37201

    Cici
    Keymaster

    Mike, I am having Lance look at this. we just got a report from another long time user with an issue (not sure if it is exactly same as yours but similar) with some version updates.

    Sorry it is taking so long to get to the root of this issue, Thank you for working through this with us.

     

    Cici

    #37202

    Mike
    Participant

    here is the link for reference: dept page

    I did jump updates and it was working fine before.

    <tr class=” “>

    I looked at the debugger and this is the error on the link I provided:  TypeError: slplus is undefined.
    thank you for looking into this
    • This reply was modified 11 months ago by  Cici. Reason: htl format
    #37218

    Marc
    Participant

    I am having the same problem as well.  Map not showing up on store pages site.

    #37289

    Mike
    Participant

    Any updates to this Lance?  Are you planning on releasing an update soon?

    #37440

    Cici
    Keymaster

    Hi Mike, Lance patched and the fix should be in 4.4.10

    SLP 4.4.10 update to JavaScript

    #37441

    Cici
    Keymaster

    @ Marc
    I do not see your Plugin Environment, but if you were receiving a JavaScript error please update 4.4.10 on SLP
    There is an article about it hereand the change log reflects the fix.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.