Unable to find Location Sensor at Admin after installing Pro Pack

Home Forums Store Locator Plus Unable to find Location Sensor at Admin after installing Pro Pack

This topic contains 12 replies, has 4 voices, and was last updated by  Lance Cleveland 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #40687

    Francisco Carlos
    Participant

    Hi,

    Plugin Environment (screenshot  attached):

    Store Locator Plus:4.4.37

    Pro Pack:4.4.04

    This Info Cached:1461663304

    WordPress Version:4.5.1

    Site URL:http://beharradaukat.eus

    MySQL Version:5.5.47

    PHP Version:5.6.20

    PHP Limit:256M

    WordPress General Limit:40M

    WordPress Admin Limit:256M

    PHP Peak RAM:8 MB

    PHP Post Max Size:8M

    Map at frontpage :  http://beharradaukat.eus

    I just installed the ‘Pro Pack’ and I was expecting to find Location Sensor at  General Settings / User Interface, as explained at https://www.storelocatorplus.com/documentation/store-locator-plus/add-on-packs/pro-pack-add-on/location-sensor/  but I only see there this section (screenshot attached):

    These settings impact how JavaScript works on your site.
    Forzar Cargar JavaScript
    Desactivar Mapas SLP

    Attachments:
    You must be logged in to view attached files.
    #40697

    Cici
    Keymaster

    Ahh, you are using a multi lingual site? Which language?

    #40698

    Cici
    Keymaster

    Ahh, you are using a multi lingual site? Which language?

    #40699

    Cici
    Keymaster

    https://www.storelocatorplus.com/new-docs-site/supportdocumentationstore-locator-plusgetting-startedlanguages/

     

    I  have mentioned this to the developer, I am not sure if that is one of those lines that needs to be translated or shouldn’t be.  There are a few posts on that subject

    #40705

    Francisco Carlos
    Participant

    Hi Cici,

    Initially the web is going to be in Spanish and Basque(Euskera). Afterwards it could be translated to many european languages…

    It has been installed with the WordPress es_ES

    Thank you for the links. I will read them as soon as possible.

    I checked the problem at my test server (http://beharradaukat.fenixinternet.com/mapa/) , without translations yet, and I got the same problem with the Location Sensor at the admin side.

    It has been installed with the WordPress es_ES (actually updated to 4.5.1–es_ES), default plugins (updated) and your Store Locator Plus:4.4.37 and Pro Pack:4.4.04

    Test site Plugin Environment:
    Store Locator Plus:4.4.37
    Pro Pack:4.4.04

    This Info Cached:1461708458
    WordPress Version:4.5.1
    Site URL:http://beharradaukat.fenixinternet.com

    MySQL Version:5.5.48
    PHP Version:5.5.21

    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:28 MB
    PHP Post Max Size:8M

    If you want to have a look I can give you the admin password.

    Kind regards,

    Francisco

    • This reply was modified 7 months, 1 week ago by  Francisco Carlos. Reason: forgot map URL
    #40759

    Cici
    Keymaster

    I have notified Lance about the translation of Location sensor in the file. WP ES,  that is the Spanish version? correct?

    Since ProPack is an add-on I believe something needs to be done on our end. If you are able to translate one or more languages there is a free add-on in it for you.

    🙂

     

    #40769

    Francisco Carlos
    Participant

    Hi Cici,

    You were right, the problem has to do with the admin side being in Spanish.

    I used a  plugin to switch the admin language (Backend Localization) to English and the missing sections appeared.

    Shouldn’t the text appear in English as default if not being present in the admin language?

    Over the next few months I will try to translate the plugin’s text into Spanish and Basque.

    Thank you!

    #40780

    Cici
    Keymaster

    Since it is the UI it doesn’t necessarily present the same way as a translation on the front end  (like a label) would…the back end ADMIN UI on the add-ons are the thins we need translated.  I have used Loco Translate to translate missing strings and then you can download the po mo file and send to us to include in an update in the plugin.. (those were the links I sent you about the translations)

    #40794

    Piani
    Participant

    I also miss this settings nowdays in my Swedish install. It have dissapered from where I was used to see it. Is it he same hickup as above or what location for this setting should I look now?

    Store Locator Plus:4.5.01

    Enhanced Map:4.3.01

    Pages:4.4.07

    Pro Pack:4.4.04

    Enhanced Results:4.3.02

    Enhanced Search:4.3.03

     

    WordPress-version:4.5.1

    #40795

    Cici
    Keymaster

    Hi Piani, et al.

    I do not know which version of SLP you are on  but on mine, it is under General/ User Interface TAB This is what it looks like for me with SLP 4.5.01 and ProPack 4.4.04.

    If you have Power it will say Power instead of ProPack, See attached.

     

    • This reply was modified 7 months ago by  Cici.
    Attachments:
    You must be logged in to view attached files.
    #40804

    Piani
    Participant

    Hi Cici

    Theres where I remember it to be but it dissapered some versions ago. Very empty as you can see on enclosed image.

    I also have locale translation issue on admin UI that I reported to Lance on Slack.

    My guess is someting happening with Legacy packs and translations.

    Attachments:
    You must be logged in to view attached files.
    #40806

    Lance Cleveland
    Keymaster

    The issue with missing settings when you are using a non-English version of WordPress has to do with the translation files.

    The older version of the settings system in Store Locator Plus used plain text, “words” in non-geek speak, to determine where to attach various settings.    The Pro Pack would do something like “add the location sensor” to the “User Interface” section on the page.

    The problem with this is that if the word “User Interface” was in the Spanish translation file for the base plugin but was NOT in the Spanish translation file for the Pro Pack the connection was not made.    That is because the English word for User Interface does not match the Spanish word however if a word is missing in a translation file, in this case the “User Interface” translation in the Pro Pack, WordPress defaults to English.     So the base plugin creates a section “Interfaz de Usuario” but the Pro Pack tries to attach to “User Interface”.

    In SLP 4.5 this issue is being resolved as the settings interface is being reworked to use “slugs” instead of “plain text”.   All of the settings tabs and sections have an identifier, the slug, that DOES NOT CHANGE regardless of language settings.   That means the Pro Pack can always find the “user interface” section regardless of language issues.   Yay!

    The bad news is there are literally hundreds of changes that need to be made in the code.  Most of it in each add-on pack.  That means updating and testing over a dozen add-on packs as well as all of the interactions between them.  It is a  TON of work.    I’m making the updates as quickly as I can.  In the meantime there are a few things you can do to help yourself and help us in the process:

     

    1) Go to the SLP translate project at WordPress and update your language.

    https://translate.wordpress.org/projects/wp-plugins/store-locator-le

    2) When at least 90% of your language has been translated, notify us so we can activate these changed on the next release.   In the meantime you *should* be able to remove the .po/.mo files in the store-locator-le/languages folder if they exist for your language.

    3) Go to your add-on that is not showing settings and translate the add-on.   We like to use Loco Translate for this.  This article can help with that.

    4) Save and download the .po/.mo files for your add on pack and send it to us via email (support@ this domain).   We will make sure it gets updated in the next release.

     

    #40809

    Lance Cleveland
    Keymaster

    SLP 4.5.02,  PRO 4.5, and POWER 4.5-alpha-07 are all in prerelease.  You can get them from your account login here.  If you don’t have access to SLP prerelease you can “buy it” for free from the home page.

    PRO & POWER use the new slug-based system reference above and should not have translation related issues for the General tab settings.

    If you know of other settings that are missing please advise and I will get them in the next patch release.

     

    Production release will be out as soon as testing passes.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.