Upload doesn't update

Home Forums Store Locator Plus Upload doesn't update

Tagged: 

This topic contains 15 replies, has 2 voices, and was last updated by  Cici 12 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #36157

    Erin
    Participant

    Hi,

    When I try to upload a file it acts like it’s uploading but then it just re-loads the location page with no new locations added.

    My list is too big to attach here but is formatted like the attached.

    I updated wordpress and the plugin recently.

    • This topic was modified 1 year ago by  Erin.
    Attachments:
    You must be logged in to view attached files.
    #36197

    Cici
    Keymaster

    Please indicate how many lines you are uploading. I assume you are referring to the CSV files as shown in your attachment.  Also what are the settings under the Bulk actions importer are you using (I.e skip geocoding etc)

     

    Do you recall the versions of SLP and ProPack you updated from – to ?

    #36199

    Erin
    Participant

    The file has 1802 lines, and includes the locations that are already loaded to the site.

    I have tried it with all 4 checked and with some unchecked

    • This reply was modified 1 year ago by  Erin.
    #36235

    Cici
    Keymaster

    Are you getting any warnings? i.e. about jquery or php or server?  What SLp versions  did you update from-to? Have you tried using the Debugging tools?

    See INFO about the Jquery warnings and also

    Google API for Developers how to add

    Troubleshooting Debugging

    #36286

    Erin
    Participant

    There are no warnings or any other messages. I upgraded to SLP <span style=”color: #000000; font-family: ‘Open Sans’, sans-serif; font-size: 13px; widows: 1; background-color: #f7fcfe;”>4.3.20 and SLP pro pack 4.3.02. Not sure how to find what version I upgraded from…</span>

    #36342

    Cici
    Keymaster

    Here is the
    Release Notes

    You would need to use the Debugger to see any Javascript errors.
    Also See Troubleshooting Ajax blocked for some reason the server is not allowing the load so am thinking there may have been some recent changes in your system configuration or an issue with memory.
    I haven’t seen this issue of late but Lance wrote an extensive article on what to check. As mentioned we have customers with very large lists loading.
    See Lances Blog some time ago about the amount of Locations he has loaded and any issues. You can search Docs and News for info on this any subject

    #36434

    Erin
    Participant

    Ok I’ve tried looking at the debugger (not sure I was looking at the right thing… debug tab in Firebug)? Didn’t see anything.

    Is there another plugin that works? This may be too difficult for me.

    #36436

    Erin
    Participant

    Could it be that I need to do something with a Google API? I know I had a calendar plugin recently that stopped working because it needed one set up…

    #36545

    Cici
    Keymaster

    Read about the Google API here, the tutorial video about it  here

    #36546

    Cici
    Keymaster

    And this is the other article Google API for server

    #36584

    Erin
    Participant

    OK I added a google API key, Google client ID and Private Key and it did not help. What else can I try??

    #36605

    Cici
    Keymaster

    Are you on a shared server or a dedicated server? It must be your server configuration. Unfortunately I have no way of helping you with that.

    #36668

    Cici
    Keymaster

    If you are on a shared Server, the issue is most likely with the configuration and limitations of your server. Google API will not change your server capacity. It only  deals with the limitation for the queries to Google for geocoding.

    Based on what you have described, as mentioned before, check with your server  provider or Your OS  for limitations.  We cannot tell you which server to get or use, that is outside the scope of this topic.

    .

    Import issues SERVER

     

    Operating System Limits

    There are various operating system limits that can cause issues including general process limitations,  directory security issues, and memory limitation issues.  All system-level applications that run on a server are beholden to the over-arching system limitations set by the server administrator.   For WordPress sites Apache (or whatever flavor web server app you use) is the primary communicator with the operating system and is most likely to be flagged for “over resource limitations”.   PHP can be flagged depending on how you have it configured to work with Apache.    Finding server-level limits means search system-level log files.

    [box]This problem is rare.[/box]

    Network Limits

    Some firewalls, especially on shared hosting environments, can throttle and time out high bandwidth data streams.

    There are several factors that work in tandem when dealing with long-running web processes.    All of these elements can cause limitations on exports (and imports).  The primary factors include:

    • Server Operating System configuration and settings.
    • PHP environment settings.
    • Web Server Application (Apache for example) configuration and settings.
    • Web Application, in this case WordPress, configuration settings.
    • Network environment settings (hosting company firewalls, bandwidth throttles, etc.)
    • User’s browser environment.

    An environment that is properly tuned to deal with large data sets will have not issues with import, exporting, or managing large lists of locations in Store Locator Plus.  The core of the product is coded to work well with large data sets with consideration for things like per-event execution time, per-event memory limitations, and reduced disk I/O operations.

    The “Debugging WordPress” section on the main Troubleshooting page can help.   Turning on WordPress debug logs can quickly identify and resolve export issues.   The web server log files (/var/log/httpd/*log on Apache RHEL servers) is also a good place to find limitation hints.

    #36670

    Cici
    Keymaster

    P.S. I just thought of something, you said you had a previous version, a part of the puzzle is missing here, did you export a csv file that you already had and are you trying to re-import it either with a new domain?

    Under Manage Locations Bulk actions,  what settings are you using on the Bulk Import actions? Are you trying to re-import a list that has already been semi geocoded?

    Under the Import button:

    Did you use the setting to Skip Geodoce or just geocode missing , skip duplication etc…

    If you can send us the csv file you are trying to import so I can test it on my site

    If you do not want to do that I can you can Try using Janitor to clen up those locations and re import

    #36673

    Erin
    Participant

    The .csv file is not from a previous version. The list does contain some locations that are already uploaded. I am not sure how to send the CSV file because it is too big. I have attached and abridged one… please try that!

    I’m not sure which checkboxes to use. I’ve tried all, none, and combos… what do you recommend?

    thanks so much for your help!!!

    Attachments:
    You must be logged in to view attached files.
    #36745

    Cici
    Keymaster

    Hi Erin,
    I sent you an email as well that provides more details but wanted to get back to you in this thread in case anyone sees it for answers in the forum.

    My response:

    By the looks of the List you provided in forum there were errors that I believe point to an issue with some of the addresses For instance in the address line you have info that cannot be geocoded per Google: That is why you are reaching your over Google Query even with API. Google can try forever and not be able to geocode.
    ​It is not in the proper format: I.e.

    Raisin Rack
    2545 Schrock Rd. Westerville, OHæ


    ​The Westervill, ,OHae is confusing the system trying to Geocode and is looping thru Google and that is why you are getting over Google query, . You cannot have special characters in your csv file format.
    ​The commercial version of Google Maps could not locate that address either and it will keep looping in the SLP system trying to geocode: It gets this response from Google Maps (not using SLP)

    ​We could not find 2545 Schrock Rd. Westerville, OHæ
    Make sure your search is spelled correctly. Try adding a city, state, or zip code.
    More Google search results for 2545 Schrock Rd. Westerville, OH

    ​There are other errors in your CSV file format, you have a comma between some and not others when you added NW.

    You should export your list in SLP to a csv file format and then you might need to use Janitor if the locations didnt delete completely. Inspect your csv file format using the best practices as discussed in the Troubleshooting and Documentation. (i.e. If you want to skip a field that column in the CSV file must be blank:) You have some locations geocoded and others that are not. You can handle that by deleting all of that column or just click on the Bulk update to skip.
    Additional info on how to set retries are under. Geocoding Errors

    Set the retires as suggested in the above.

    If the developer finds anything else then he will address it in next few days.

    Thanks

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.