Warning: Missing argument 4 for SLPlus

Home Forums Store Locator Plus Warning: Missing argument 4 for SLPlus

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 6 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40936

    Rafal
    Participant

    After latest update getting this  error -Warning: Missing argument 4 for SLPlus::get_item(), called in /wp-content/plugins/slp-enhanced-map/include/class.userinterface.php on line 78 and defined in /wp-content/plugins/store-locator-le/include/class.slplus.php on line 846

    Can you tell me what could be the reason behind it ?

    • This topic was modified 6 months, 3 weeks ago by  Rafal.
    • This topic was modified 6 months, 3 weeks ago by  Rafal.
    #40956

    Cici
    Keymaster

    Hi Rafal

    Latest update to WP, SLP, ? Your theme?

    Could you provide your Plugin Environment (see Posting Guidelines)? Need to know what versions, of SLP and add-ons  and your WP versions, etc. and your site url. ( sometimes we can find the issue using Troubleshooting tools, browser tools)

     

    #40985

    Rafal
    Participant

    Store Locator Plus:4.5.03
    Enhanced Map:4.3.01

    This Info Cached:1462887280
    WordPress Version:4.5.2
    Network Active:No
    Site URL:http://halcyonpoland.com/dilerzy

    MySQL Version:5.5.44
    PHP Version:5.3.29

    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:88 MB
    PHP Post Max Size:64M

    • This reply was modified 6 months, 3 weeks ago by  Rafal.
    #41019

    Cici
    Keymaster

    Troubleshooting

    Debug your plugin.

    The first error may be because that Plugin or theme is not using Current WP compatibility  jquery and that will create MAP ISSUES. We posted a blog about that here and here is additional  info  on WP about 4.5  issues,  Check  PhP versions, they should be updated per WP best practices   see  info on what you can do to request that from your host.

    You have FAILURES,, using any Inspect tools from your browsers (See the Debug video or Docs in Troubleshooting)
    the first one noted here  is a result of incorrect html reference with lightbox . Is this part of your theme? Is it using an outdated jquery version  that  may not have shown errors before , but  now will  with latest WP 4.5 updates .  See that WP link above for more info .

    jquery.colorbox.js:13 Uncaught ReferenceError: lightbox_html is not defined

     

    **This next error mentions multiple Google MAP APIS, you have more than one plugin loading and trying to connect to Google Maps and this is a conflict with SLP.

     

    js?language=pl&ver=4.5.03:92 You have included the Google Maps API multiple times on this page. This may cause unexpected errors.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.