For our MySLP users, these types of issues do not affect you. All of the MySLP servers are running PHP7 with the latest security patches. Ahhhh, the benefits of using a managed service. Sit back and relax, PHP compatibility is one less issue to worry about.
For our WordPress plugin users
Store Locator Plus for WordPress version 4.9 has some PHP compatibility issues. It currently will only run on sites that are using PHP version 5.4 or higher.
An update to SLP , Power, and Premier 4.9.1 are in development that will restore PHP 5.3 compatibility. Those updates are slated to be release by the end of November, 2017. Experience is not impacted by this issue.
For our PHP 5.2 users, unfortunately we can no longer support that release of PHP. We are using a new architecture based on a PHP function that was added to PHP in February 2012. That change in SLP 4.9 means sites using PHP 5.2 can no longer use PHP.
PHP Recommendations and History
For all users it is recommended you upgrade to PHP 5.6 at a minimum. There are dozens of security patches in PHP between each point release (5.2 => 5.3 => 5.4, etc.) some of which are significant.
|5.2||5.2.17||6 January 2011|
|5.3||5.3.29||14 August 2014|
|5.4||5.4.45||3 September 2015|
|5.5||5.5.38||21 July 2016|
If your host is not allowing you to upgrade to a newer release or a WordPress plugin or theme breaks on PHP 5.6+ you should ask why. WordPress (and Store Locator Plus) run perfectly well on PHP 7 which is the current recommendation from WordPress due to the notable performance improvements in version 7.