Store Locator Plus® was updated today with a number of improvements over the 5.2 release.   Users will find that the Locations management screen is much faster when the screen options sets pagination length to more than 100 records.  The update also ensures that those users that set their location list to more than 512 locations can still use the Export options available in the Professional and Enterprise level of service, or that have the Power add on installed if using the WordPress plugins.

SaaS Performance Boost

While the 5.3 release of Store Locator Plus® includes a number of performance enhancements across-the-board, our SaaS service has received some additional updates that allow us to process location and map requests a little faster.   This is thanks to working with a controlled software stack where we know the exact version of WordPress, PHP, and all the libraries involved to squeeze as much performance as possible from the code.

Users should notice faster response when loading the map on a page, especially on sites with more than a few dozen locations being displayed.

SEO Pages

Work has been ongoing with the SEO Pages, aka Store Pages, that are part of the Power add on for WordPress plugin users.   The changes added functionality to Store Pages, like the ability to output [slp_option …] settings in a page template.     Query overhead has also been reduced.

Much of the work on SEO Pages has been done to prepare for the launch of this feature in the SaaS service.    Our goal is to launch Store Pages on the SaaS product Enterprise level by Q2’2020.

Premier Add On

A new feature in the Premier add on for WordPress plugin users is the ability to display a Gravity Forms form in place of the standard “No results found.” message when a users searches for a zip code where there are no locations in the area.    You will need a valid Gravity Forms license and create a form to attach this setting to.

We are investigating Gravity Forms licensing while updating our theme user user interfaces for MySLP as we explore the possibility of bringing this feature to our MySLP users.

Premier Subscription Compatibility Notice

Users of the WordPress plugins that are utilizing the Premier add on should note that the 5.3 version of the Premier plugin requires the site to be running WordPress 5.3.   This is due to breaking changes that stopped backwards compatibility on the Walker class in WordPress 5.3.      You can opt to skip the Premier upgrade, however it is recommended your WordPress site is running 5.3 for security concerns.

Our SaaS users do not need to worry about these sort of things.   We’ve already tested the software and upgraded all the underlying software required to keep the My Store Locator Plus® running.

Interested in not having to worry about backward-compatibility and breaking changes on your website?   Maybe it is time you check out our SaaS service:

Leave a Reply