Posted on

MacBook Pro Video Problems Solved

I’ve posted about this a few times on this site and now I feel like a fool for not discovering the problem sooner.     I’m not 100% certain if the issue is an HP monitor issue, a cable manufacturer issue, or and Apple hardware/OS/firmware issue.   All I know for certain is that a couple different brands of cell phones will cause my monitors to lose video signal and “flicker” on/off or show video artifacts.     Sometimes the video loss runs in cycles as fast as 1-second on/ 1-second off.  Sometimes the monitors power off for minutes-at-a-time.     Sometimes I just see horrible bands of pixelation run horizontally or vertically on the screen.    In many cases OS/X starts logging all kinds of video events in the system logs, but I am certain that is a side effect of a video data error that is not being handled as well as it could be.

At the end of the day the problem is easy to fix.   Move my cell phone away from my monitors.

Turns out that ALL THREE of my phones, an older HTC Incredible, a newer HTC Incredible 4G LTE, and a brand new Samsung Galaxy S5 all cause the problem.    It also turns out that the problem varies in intensity based on the lunar cycle and its alignment with the solar winds or some other cosmic crap like that.     What I do know is that when the problem starts my productivity goes to hell and as I can never guess when I can see my code or my browser.

For some reason the electro-magnetic fields (EMF) from the phone are causing all hell to break loose on the displayport video communications to/from the monitor.   That causes a cascade of problems which inevitably results in a monitor powering off or a black screen where video should be.     After multiple red herrings, running down innumerable rabbit holes, and even going so far as to not only swap video cables and monitors but also a brand new MacBook Pro,  the real issue is basic electro-magnetic interference and the solution is as simple as “move my cell phone”.

Here is the recap I sent to Apple Support today regarding the issue.   Hopefully someone will stumble across this online and save themselves some headaches as well.

 

Apple Support Communication

I finally figured out the monitor flicker, power cycle, and pixelation artifacts problem with my monitors after MONTHS of dealing with the issue.

This is really crazy, but it is without-a-doubt what is going on here:

PROXIMITY OF CELL PHONE TO VIDEO HARDWARE

I haven’t yet narrowed down the issue to exactly what the root cause is, but here is what I know for a fact:

1) This happens with my older HTC Inredible 4G LTE phone.
2) This happens with my new Samsung Galaxy S5 phone.
3) This happens ONLY on displayport but HDMI does not appear to be impacted.

4) The problem appears to only happen with the phone is within 5cm of the monitor end of the displayport cable.

5) The problem happens on the HP ZR2440w monitor and other HP monitors using DisplayPort as well as a Samsung monitor using DisplayPort  (I no longer have that monitor, wish I could re-test).

6) Portrait or landscape mode was a red herring.

7) I could not reproduce the issue by placing the phone near (even touching) the MacBook end of the displayport cables.
After 5 days of trying to capture the behavior with my camera-phone and the problem suddenly going away after picking up my phone it finally came to me.      Move the phone back and TOUCH the display cable… bam powers off the display like a wireless power switch.     Move it away, pixelation, then the monitor comes back on.

I then tested the FIRST displayport as I have only seen this happen on the 2nd displayport (furthest from power port on the MacBook) and like magic the first monitor turned off as soon as I touched the phone to the cable.

After multiple tests I’ve learned that I need to just be close to the cable (it is not a physical cable connection issue, verified that a few times).   Within 1-2cm the monitor powers off 60% of the time.   Within 2-5cm the monitor may power off (10% of the time) or display pixelation artifacts or the notorious “ants” problem (30% of the time).

It *may* be the minidisplayport-to-displayport cables I am using, however I have swapped out these cables and at least one set of cables is NOT from the same manufacturer.

To be determined:

a) Is this a cable shielding issue?
b) Is this a monitor build issue?

c) Why does the software react to EMF introduced at the hardware level?   (bad error checking/trapping in the video processing firmware/software?)

Just though I’d share so you can close this ticket and possibly disseminate this information to support channels.     I’m guessing my cell phone is not the only possible source of EMF that can cause external display issues.   Given the number of online posts about similar problems I would venture a guess that more than a few Apple support calls and hardware returns may be related to similar EMF-related issues.

I am very techy and know all about EMF but it never occurred to me that the EMF from my phone would affect a displayport signal to the point of being able to actually power down a monitor IMMEDIATELY.

Good to know what it is.  When I have more time I’ll do more homework and post my findings online.

In the meantime I’m relocating my phone charging cable to not be under my monitors.