0 comments on “API keys with referer restrictions cannot be used”

API keys with referer restrictions cannot be used

You’ve tried typing in addresses into your WordPress Store Locator Plus® map page but always get “location not found”. Being a tech savvy person you took a look at your browser developer console and notice an “API keys with referer restrictions cannot be used with this API.” in the JavaScript console.

Thankfully our MySLP users don’t have to deal with this sort of thing; but if you are using the self-managed WordPress plugins, read on.

You’ve found the telltale sign that your restricted browser API key has been set in the Store Locator Plus geocoding key field. Coming soon with the WordPress Store Locator Plus 5.0.4 release is a new message that will show in your map results telling you what error codes Google is sending back.

WPSLP Message when a GoogleAPI key has a referer restriction set — likely the result of saving the Browser Key in the Geocoder Key setting in WPSLP.

There are a couple of correct ways to setup your Google API keys for Store Locator Plus

3 comments on “Store Locator Plus and WordPress 4.9.1 Updates”

Store Locator Plus and WordPress 4.9.1 Updates

It has been a busy week for WordPress and all the updates and patches going around.    For those on our MySLP managed service, sit back and relax.  You’re good.    While you may wait a little longer for some new features and a couple of minor patches you are not going to be affected by software updates.   You’re good.

For WordPress users we’ve been busy chasing down some notable functionality issues with Store Locator Plus and the Add Ons for WordPress since WordPress 4.9 and 4.9.1 hit the update queue on your sites.