News

3 comments on “Store Locator Plus and WordPress 4.9.1 Updates”

Store Locator Plus and WordPress 4.9.1 Updates

It has been a busy week for WordPress and all the updates and patches going around.    For those on our MySLP managed service, sit back and relax.  You’re good.    While you may wait a little longer for some new features and a couple of minor patches you are not going to be affected by software updates.   You’re good.

For WordPress users we’ve been busy chasing down some notable functionality issues with Store Locator Plus and the Add Ons for WordPress since WordPress 4.9 and 4.9.1 hit the update queue on your sites.

3 comments on “Store Locator Plus 4.9 and PHP Compatibility”

Store Locator Plus 4.9 and PHP Compatibility

For our MySLP users, these types of issues do not affect you.  All of the MySLP servers are running PHP7 with the latest security patches.   Ahhhh, the benefits of using a managed service.   Sit back and relax, PHP compatibility is one less issue to worry about.

For our WordPress plugin users

Store Locator Plus for WordPress version 4.9 has some PHP compatibility issues.     It currently will only run on sites that are using PHP version 5.4 or higher.

An update to SLP , Power, and Premier 4.9.1 are in development that will restore PHP 5.3 compatibility.    Those updates are slated to be release by the end of November, 2017.  Experience is not impacted by this issue.

PHP 5.2

For our PHP 5.2 users, unfortunately we can no longer support that release of PHP.   We are using a new architecture based on a PHP function that was added to PHP in February 2012.   That change in SLP 4.9 means sites using PHP 5.2 can no longer use PHP.

 

PHP Recommendations and History

For all users it is recommended you upgrade to PHP 5.6 at a minimum.  There are dozens of security patches in PHP between each point release (5.2 => 5.3 => 5.4, etc.) some of which are significant.

For reference, here is the PHP Version Release History.   Supported until means the last date the PHP language was fixing problems and patching security holes.
VersionLatestSupported until
5.25.2.176 January 2011
5.35.3.2914 August 2014
5.45.4.453 September 2015
5.55.5.3821 July 2016

 If your host is not allowing you to upgrade to a newer release or a WordPress plugin or theme breaks on PHP 5.6+ you should ask why.    WordPress (and Store Locator Plus) run perfectly well on PHP 7 which is the current recommendation from WordPress due to the notable performance improvements in version 7.

0 comments on “Location Sensor Can Help Visitors Find Your Store”

Location Sensor Can Help Visitors Find Your Store

Finding  Locations Near You

How important is it for people to find a location nearest them?  “Near Me” has been a top-ranked search term on Google for the past seven years. This may be the number one reason to use a location sensor.  Research indicates that the common phrases of “near me” in Google searches is a top-ranked query.   The phrase “handyman near me” might return a  cloud based app that in turn redirects  the users search to some  popular apps but how does your browser,  Google Maps or other platform know where you are?

Location Sensor

Enter location sensor, a browser-based tool that detects where a user is at the time of search.  On GPS-enabled mobile devices it returns the precise location using the device’s built-in GPS sensor.  For the Store Locator Plus users the location sensor can be enabled by checking a box under General Settings.   WordPress Plugin users will need the Power add on.   MySLP service users will need to be subscribed to the Power, Professional, or Enterprise plan.

Mobile App using location sensor
Location sensors in mobile apps can guide people to your store.

Using HTTPS Improves Sensor Performance

Google Chrome’s v 50 and higher ( the most popular browser with the largest market share  at this time)  requires site urls to be served over a secured site before it will allow the location of the user to be transmitted.  They have stated that location is sensitive data and determined that HTTPS versus HTTP  be  required to protect the privacy of your users’ location data.  Other popular browsers , such as Mozilla Firefox, may submit a pop-up box asking the user to grant permission for their location to be known.

In short, if your site is using the location sensor feature it must get an SSL certificate and be serving pages on an https address.   Many browser disable multiple features if you are not a secure site, including the location sensor.   It won’t be long before ALL browsers disable location sensor support if you are not hosting an https site.

Location Sensors Can Increase Sales

If you have a physical location that counts on people walking in the door to make a sale, adding Google Maps and employing the location sensor can have a notable impact on your walk-in traffic.    Your first step is to get an SSL certificate on your site so you can serve secure pages; This also helps boost your Google search rank.   Once you have that completed put Google Maps software that supports the locations sensor on your site.     Add a couple of posts to your site that relate to your business such as “Boutique Near Me” and drop the map code on that post.   It won’t happen overnight, but as your site starts to generate traffic the map will lead people to your store.

 

Have questions?   Contact us.